<!doctype html>
<html class="no-js site--joroistenlehti  user--is-not-subscriber user--is-not-company-subscriber" lang="fi" prefix="og: http://ogp.me/ns#">
	<head>
		<meta charset="utf-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		<title>Salla Huovinen lopettaa JoU:n pesisnaisten valmentajana | Urheilu | Joroisten Lehti</title>
		<link rel="stylesheet" href="https://a.joroistenlehti.fi/styles/d9ba9ccf/styles/diks-news.css">
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Merriweather:400,400i,700,700i">

		<link rel="manifest" href="/manifest.webmanifest">
			<script>
		window.JankkoSSOConfig = {
			accountOrigin: "JORL"
		};
  </script>

	<script id="jankko-sso-script" src="https://sso.joroistenlehti.fi/assets/jankko-sso-client.min.js"></script>
	
		<script>(function() { var host = window.location.hostname; var element = document.createElement('script'); var firstScript = document.getElementsByTagName('script')[0]; var url = 'https://quantcast.mgr.consensu.org' .concat('/choice/', '48JnYHj1cxc-Y', '/', host, '/choice.js'); var uspTries = 0; var uspTriesLimit = 3; element.async = true; element.type = 'text/javascript'; element.src = url; firstScript.parentNode.insertBefore(element, firstScript); function makeStub() { var TCF_LOCATOR_NAME = '__tcfapiLocator'; var queue = []; var win = window; var cmpFrame; function addFrame() { var doc = win.document; var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]); if (!otherCMP) { if (doc.body) { var iframe = doc.createElement('iframe'); iframe.style.cssText = 'display:none'; iframe.name = TCF_LOCATOR_NAME; doc.body.appendChild(iframe); } else { setTimeout(addFrame, 5); } } return !otherCMP; } function tcfAPIHandler() { var gdprApplies; var args = arguments; if (!args.length) { return queue; } else if (args[0] === 'setGdprApplies') { if ( args.length > 3 && args[2] === 2 && typeof args[3] === 'boolean' ) { gdprApplies = args[3]; if (typeof args[2] === 'function') { args[2]('set', true); } } } else if (args[0] === 'ping') { var retr = { gdprApplies: gdprApplies, cmpLoaded: false, cmpStatus: 'stub' }; if (typeof args[2] === 'function') { args[2](retr); } } else { queue.push(args); } } function postMessageEventHandler(event) { var msgIsString = typeof event.data === 'string'; var json = {}; try { if (msgIsString) { json = JSON.parse(event.data); } else { json = event.data; } } catch (ignore) {} var payload = json.__tcfapiCall; if (payload) { window.__tcfapi( payload.command, payload.version, function(retValue, success) { var returnMsg = { __tcfapiReturn: { returnValue: retValue, success: success, callId: payload.callId } }; if (msgIsString) { returnMsg = JSON.stringify(returnMsg); } event.source.postMessage(returnMsg, '*'); }, payload.parameter ); } } while (win) { try { if (win.frames[TCF_LOCATOR_NAME]) { cmpFrame = win; break; } } catch (ignore) {} if (win === window.top) { break; } win = win.parent; } if (!cmpFrame) { addFrame(); win.__tcfapi = tcfAPIHandler; win.addEventListener('message', postMessageEventHandler, false); } }; makeStub(); var uspStubFunction = function() { var arg = arguments; if (typeof window.__uspapi !== uspStubFunction) { setTimeout(function() { if (typeof window.__uspapi !== 'undefined') { window.__uspapi.apply(window.__uspapi, arg); } }, 500); } }; var checkIfUspIsReady = function() { uspTries++; if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) { console.warn('USP is not accessible'); } else { clearInterval(uspInterval); } }; if (typeof window.__uspapi === 'undefined') { window.__uspapi = uspStubFunction; var uspInterval = setInterval(checkIfUspIsReady, 6000); } })();</script>
		<link rel="apple-touch-icon" href="/icon-512.png">
	<link rel="apple-touch-icon" sizes="512x512" href="/icon-512.png">
	<link rel="apple-touch-icon" sizes="256x256" href="/icon-256.png"><link rel="apple-touch-startup-image" href="/iphone5_splash.png" media="(device-width: 320px) and (device-height: 568px) and (-webkit-device-pixel-ratio: 2)">
	<link rel="apple-touch-startup-image" href="/iphone6_splash.png" media="(device-width: 375px) and (device-height: 667px) and (-webkit-device-pixel-ratio: 2)">
	<link rel="apple-touch-startup-image" href="/iphoneplus_splash.png" media="(device-width: 621px) and (device-height: 1104px) and (-webkit-device-pixel-ratio: 3)">
	<link rel="apple-touch-startup-image" href="/iphonex_splash.png" media="(device-width: 375px) and (device-height: 812px) and (-webkit-device-pixel-ratio: 3)">
	<link rel="apple-touch-startup-image" href="/iphonexr_splash.png" media="(device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 2)">
	<link rel="apple-touch-startup-image" href="/iphonexsmax_splash.png" media="(device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 3)">
	<link rel="apple-touch-startup-image" href="/ipad_splash.png" media="(device-width: 768px) and (device-height: 1024px) and (-webkit-device-pixel-ratio: 2)">
	<link rel="apple-touch-startup-image" href="/ipadpro1_splash.png" media="(device-width: 834px) and (device-height: 1112px) and (-webkit-device-pixel-ratio: 2)">
	<link rel="apple-touch-startup-image" href="/ipadpro3_splash.png" media="(device-width: 834px) and (device-height: 1194px) and (-webkit-device-pixel-ratio: 2)">
	<link rel="apple-touch-startup-image" href="/ipadpro2_splash.png" media="(device-width: 1024px) and (device-height: 1366px) and (-webkit-device-pixel-ratio: 2)"><link rel="alternate" type="application/rss+xml" title="Joroisten Lehti" href="https://www.joroistenlehti.fi/feed/rss">
<meta name="facebook-domain-verification" content="4xtdxvaklxywo753n2rjnzack7p2st"><script>
var pageData = {};
pageData.article = {
	'id':'4310593',
	'url':'https\u003A\/\/www.joroistenlehti.fi\/urheilu\/4310593',
	'published': '2021\u002D09\u002D28\u002016\u003A30',
	'modified': '2021\u002D09\u002D28\u002016\u003A25',
	'storyType':'story',
	'paywall':'paid',
	'headlinePrefix':'',
	'headline':'Salla\u0020Huovinen\u0020lopettaa\u0020JoU\u003An\u0020pesisnaisten\u0020valmentajana',
	'lead':'',
	'description':'',
	'priority':'default',
	'style':'default',
	'mainImage':'https://i.media.fi/incoming/vxemqk/7048838.jpg/alternates/FREE_960/7048838.jpg',
	'teaserImage':'',
	'authors': ['Rauno\u0020Yl\u00F6nen'],
	'topics': ["Liikunta ja urheilu","Urheilutapahtumat","Pes\u00e4palloilu","Superpesis (Miehet)","Urheiluvalmennus","Suomi (Valtio)","Pohjoismaat","Ty\u00f6el\u00e4m\u00e4","Sosiaalikysymykset","Talviurheilu","Pohjois-Eurooppa","Ammattiurheilu","J\u00e4\u00e4kiekko","Jyv\u00e4skyl\u00e4n kaupunki","Eurooppa","Perhe","Miesten j\u00e4\u00e4kiekko","Nuoret","Historia","Ammattilaisj\u00e4\u00e4kiekko"],
	'elementCount': 2,
	'paragraphCount': 2,
	'contentLength': 493,
	'imageCount': 1
}
pageData.section = {
	'name': 'Urheilu',
	'uname': 'urheilu',
	'url': 'https\u003A\/\/www.joroistenlehti.fi\/urheilu\/'
}
pageData.publication = {
	'name': 'joroistenlehti',
	'url': 'https\u003A\/\/www.joroistenlehti.fi\/',
	'engage': 'JORL',
	'paywallEnabled': true,
	'env':'prod'
}
pageData.user = {}
pageData.companyUser = {}

function isPwa() {
	// window.navigator.standalone = iOS
	// window.matchMedia('(display-mode: standalone)').matches = Android/universal
	return (window.navigator.standalone) ||
	       (["fullscreen", "standalone", "minimal-ui"].some(
	        function(displayMode) { return window.matchMedia('(display-mode: ' + displayMode + ')')
	        .matches }));
}

pageData.general = {
	'browseMode': (isPwa() ? 'pwa' : 'browser')
}

</script>
<meta property="og:site_name" content="Joroisten Lehti"/>
<meta property="og:locale" content="fi_FI"/>

    


<link rel="canonical" href="https://www.warkaudenlehti.fi/urheilu/4310593" />
<meta property="og:url" content="https://www.joroistenlehti.fi/urheilu/4310593" />
<meta name="description" content="JoU:n naisten suomensarjan pesäpallojoukkuetta viisi vuotta yhteen putkeen luotsannut Salla Huovinen lopettaa valmennustehtävät tähän kauteen, joka Jo..." />
<meta name="keywords" content="Liikunta ja urheilu, Urheilutapahtumat, Pesäpalloilu, Superpesis (Miehet), Urheiluvalmennus, Suomi (Valtio), Pohjoismaat" />
	<meta property="og:title" content="Salla Huovinen lopettaa JoU:n pesisnaisten valmentajana" />
<meta property="og:description" content="JoU:n naisten suomensarjan pesäpallojoukkuetta viisi vuotta yhteen putkeen luotsannut Salla Huovinen lopettaa valmennustehtävät tähän kauteen, joka Jo..." />
<meta property="og:image" content="https://i.media.fi/incoming/vxemqk/7048838.jpg/alternates/LANDSCAPE_960/7048838.jpg" />
<meta property="og:image:width" content="960" />
<meta property="og:image:height" content="540" />
<meta property="og:type" content="article" />
<meta property="article:author" content="Rauno Ylönen" />
<meta property="article:section" content="Urheilu" />
<meta property="article:tag" content="Liikunta ja urheilu" />
<meta property="article:tag" content="Urheilutapahtumat" />
<meta property="article:tag" content="Pesäpalloilu" />
<meta property="article:tag" content="Superpesis (Miehet)" />
<meta property="article:tag" content="Urheiluvalmennus" />
<meta property="article:tag" content="Suomi (Valtio)" />
<meta property="article:tag" content="Pohjoismaat" />
<meta property="article:modified_time" content="2021-09-28T16:25:07+03:00" />
<meta property="article:published_time" content="2021-09-28T16:30:00+03:00" />


<meta name="cXenseParse:recs:recommendable" content="true"/>
<meta name="cXenseParse:pageclass" content="article"/>
<meta name="cXenseParse:recs:articleid" content="4310593" />
<meta name="cXenseParse:recs:kes-origin" content="Warkauden Lehti" />
<meta name="cXenseParse:kes-origin" content="Warkauden Lehti" />
<meta name="cXenseParse:recs:kes-isad" content="false" />
<meta name="cXenseParse:kes-isad" content="false" />
<meta name="cXenseParse:recs:kes-hasimage" content="true" />
<meta name="cXenseParse:kes-hasimage" content="true" />
<meta name="cXenseParse:recs:kes-source" content="Warkauden Lehti" />
<meta name="cXenseParse:kes-source" content="Warkauden Lehti" />
<meta name="cXenseParse:recs:kes-articletype" content="Story" />
<meta name="cXenseParse:kes-articletype" content="Story" />
<meta name="cXenseParse:recs:kes-siterecsname" content="Joroisten Lehti" />
<meta name="cXenseParse:recs:kes-keywordtag" content="Liikunta ja urheilu" />
<meta name="cXenseParse:kes-keywordtag" content="Liikunta ja urheilu" />
<meta name="cXenseParse:recs:kes-keywordtag" content="Urheilutapahtumat" />
<meta name="cXenseParse:kes-keywordtag" content="Urheilutapahtumat" />
<meta name="cXenseParse:recs:kes-keywordtag" content="Pesäpalloilu" />
<meta name="cXenseParse:kes-keywordtag" content="Pesäpalloilu" />
<meta name="cXenseParse:recs:kes-keywordtag" content="Superpesis (Miehet)" />
<meta name="cXenseParse:kes-keywordtag" content="Superpesis (Miehet)" />
<meta name="cXenseParse:recs:kes-keywordtag" content="Urheiluvalmennus" />
<meta name="cXenseParse:kes-keywordtag" content="Urheiluvalmennus" />
<meta name="cXenseParse:recs:kes-keywordtag" content="Suomi (Valtio)" />
<meta name="cXenseParse:kes-keywordtag" content="Suomi (Valtio)" />
<meta name="cXenseParse:recs:kes-keywordtag" content="Pohjoismaat" />
<meta name="cXenseParse:kes-keywordtag" content="Pohjoismaat" />
<meta name="cXenseParse:recs:publishtime" content="2021-09-28T16:30:00+03:00" />
<meta name="cXenseParse:kes-paywall" content="paid" />
<meta name="cXenseParse:recs:kes-paywall" content="paid" />
<meta name="cXenseParse:kes-storyType" content="story" />
<meta name="cXenseParse:recs:kes-storyType" content="story" />
<meta name="cXenseParse:kes-priority" content="default" />
<meta name="cXenseParse:recs:kes-priority" content="default" />
<meta name="cXenseParse:kes-style" content="default" />
<meta name="cXenseParse:recs:kes-style" content="default" />
<meta name="cXenseParse:kes-template" content="default" />
<meta name="cXenseParse:recs:kes-template" content="default" />

		
	
		
<script>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</script>

<script async='async' src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script>



<script>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</script>

		
		

<script>
initTagManager = (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KTJNB7R');

var dataLayer = window.dataLayer || [];
window.dataLayer.push({'event':'pageDataPush','pageData': window.pageData});
window.initTagManager;

(function () {
  var user = {};
  var companyUser = {};
  var articleState;
  var paywallEnabled = (typeof window.pageData.publication.paywallEnabled !== undefined) ? window.pageData.publication.paywallEnabled : true;

	    // free is always the safer fallback
    var articlePaywall = "free";

    if (window.pageData && window.pageData.article && window.pageData.article.paywall) {
      articlePaywall = window.pageData.article.paywall;
    }

    if (articlePaywall == "free" || !paywallEnabled) {
      articleState = "full";
    } else {
      articleState = "preview";
    }
	
  function getCookie(name) {
    name = name + '=';
    const decodedCookie = decodeURIComponent(document.cookie);
    const cookies = decodedCookie.split(';');

    for (let i = 0; i < cookies.length; i++) {
      const cookie = cookies[i].trim();
      if (cookie.indexOf(name) == 0) {
        return cookie.substring(name.length, cookie.length);
      }
    }
  }

  function pushDataLayerEvent() {
    let segmentsCookie = getCookie('jankkosegments');

    if (segmentsCookie) {
      let segmentsData = JSON.parse(segmentsCookie);
      let segments = segmentsData.segments;

      if (segments && typeof segments === 'object') {
          user.segments = segments;
      }
    }

    window.dataLayer.push({'event': 'userDataPush',
      'pageData': {
                  'article': {
            'state': articleState
          },
                'user': user,
        'companyUser': companyUser
      }
    });
  }

  if (typeof JankkoSSOClient !== 'undefined') {
    JankkoSSOClient.getSession().then(function(data) {
      if (data) {
        user.id = data.user ? data.user.id : undefined;
        user.products = data.active_products;
        user.permissions = data.permissions;

        if (data.company_subscription) {
          companyUser.id = data.company_subscription.user ? data.company_subscription.user.id : undefined;
          companyUser.products = data.company_subscription.active_products;
          companyUser.permissions = data.company_subscription.permissions;
        }

        var tuloUserPermissions = Array.isArray(user.permissions) ? user.permissions : [];
        var companyUserPermissions = Array.isArray(companyUser.permissions) ? companyUser.permissions : [];

        var permissions = tuloUserPermissions.concat(companyUserPermissions);

                  if (articlePaywall != "free" && permissions.includes("paywall")) {
            articleState = "full";
          }
              }

      pushDataLayerEvent();
    })
    .catch(function(error) {
      console.log(error);
      pushDataLayerEvent();
    });
  } else {
    pushDataLayerEvent();
  }
}());

</script>


	</head>
	<body>
		<div class="skip-link-navigation skip-link-navigation--top" role="navigation">
		<ul class="navigation navigation--skip-links">
							<li class="navigation__item"><a class="navigation__link a11y__screen-reader a11y__screen-reader--focusable" href="#sisalto">Siirry suoraan sisältöön</a></li>
					</ul>
	</div>

		<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KTJNB7R"
    height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

						<div class="navbar navbar--fixed">
	<div class="layout-container">
		<div class="navbar__primary" role="navigation">
				<ul class="navigation navigation--main js-waypoint-navbar-primary" id="valikko">
		<li class="navigation__item" id="osastot">
			<a class="navigation__link navbar__dropdown-open js-toggler" href="#osastot" data-toggle="osastovalikko" aria-label="Avaa sisältövalikko"><span class="icon icon--navigation"></span> Sisältö</a>
			<a class="navigation__link navbar__dropdown-close" href="#valikko" aria-label="Sulje sisältövalikko"><span class="icon icon--navigation"></span> Sisältö</a>
			<div class="navbar__dropdown" id="osastovalikko">
				<div class="layout-container">
					<div class="grid grid--auto">
													<div class="grid__column">
																	<h2 class="navigation__sub-heading">Joroisten Lehti</h2>
								
								<ul class="navigation navigation--sub">
																			<li class="navigation__item "><a class="navigation__link" href="/">Etusivu</a></li>
																			<li class="navigation__item "><a class="navigation__link" href="/uusimmat/">Uusimmat</a></li>
																			<li class="navigation__item "><a class="navigation__link" href="/luetuimmat/">Luetuimmat</a></li>
																			<li class="navigation__item hide-above-large"><a class="navigation__link" href="/nakoislehti/">Näköislehti</a></li>
																			<li class="navigation__item "><a class="navigation__link" href="/haku/">Haku</a></li>
																	</ul>
							</div>
						
													<div class="grid__column">
																	<h2 class="navigation__sub-heading">Osastot</h2>
								
								<ul class="navigation navigation--sub">
																			<li class="navigation__item "><a class="navigation__link" href="/paikalliset/">Paikalliset</a></li>
																			<li class="navigation__item "><a class="navigation__link" href="/urheilu/">Urheilu</a></li>
																			<li class="navigation__item "><a class="navigation__link" href="/teemat/">Teemat</a></li>
																			<li class="navigation__item "><a class="navigation__link" href="/paakirjoitus-mielipide/">Pääkirjoitus &amp; mielipide</a></li>
																	</ul>
							</div>
						
											</div>
				</div>
			</div>
		</li>
	</ul>

			<ul class="navigation navigation--main js-waypoint-navbar-secondary" style="display:none;">
			<li class="navigation__item">
				<a class="navigation__link js-link-back-or-home" href="/"><span class="icon icon--back"></span> Takaisin</a>
			</li>
		</ul>
	
	
		</div>

		<div class="navbar__secondary" role="navigation">
				<ul class="navigation navigation--main" id="kotivalikko">
														<li class="navigation__item hide-below-large"><a class="navigation__link" href="/nakoislehti/">Näköislehti</a></li>
																<li class="navigation__item hide-from-subscribers"><a class="navigation__button-link" href="https://oma.media.fi/joroisten-lehti/tilaa/">Tilaa</a></li>
									
					<li class="navigation__item" id="asiakas">
				<a class="navigation__link navbar__dropdown-open js-toggler" href="#asiakas" data-toggle="asiakasvalikko" aria-label="Avaa asiakasvalikko"><span class="icon icon--user"></span> <span class="hide-from-company-subscribers">Asiakas</span><span class="show-for-company-subscribers">Asiakas (yritys)</span></a>
				<a class="navigation__link navbar__dropdown-close" href="#kotivalikko" aria-label="Sulje asiakasvalikko"><span class="icon icon--user"></span> <span class="hide-from-company-subscribers">Asiakas</span><span class="show-for-company-subscribers">Asiakas (yritys)</span></a>
				<div class="navbar__dropdown" id="asiakasvalikko">
					<div class="layout-container">
						<div class="grid grid--auto grid--reversed">
															<div class="grid__column navigation__main-content">
																			<div class="show-for-company-subscribers">
																							<h2 class="navigation__sub-heading">Yritystilaus tunnistettu</h2>
											
																							<div class="navigation__sub-content">
													<p>Voit käyttää palvelun kaikkia sisältöjä vapaasti. Jos haluat kommentoida, kirjaudu sisään henkilökohtaisella Mediatunnuksella.</p>
												</div>
																					</div>
									
																			<h2 class="navigation__sub-heading" id="jankko-sso-username">Tili</h2>
									
									<ul class="navigation navigation--sub" id="jankko-sso-links">
																					<li class="navigation__item"><a class="navigation__link" href="javascript:if(typeof window.__tcfapi !== &#039;undefined&#039;){window.__tcfapi(&#039;displayConsentUi&#039;,2,function(){});}else{window.location=&#039;https://www.keskisuomalainen.com/tietosuojalauseke&#039;;};">Evästevalinnat</a></li>
																			</ul>
								</div>
							
															<div class="grid__column">
																			<h2 class="navigation__sub-heading">Palvelut</h2>
									
									<ul class="navigation navigation--sub">
																					<li class="navigation__item"><a class="navigation__link" href="https://oma.media.fi/joroisten-lehti/">Asiakaspalvelu</a></li>
																					<li class="navigation__item"><a class="navigation__link" href="https://mediamyynti.savonmedia.fi/yhteystiedot/keski-savo/">Mediamyynti</a></li>
																					<li class="navigation__item"><a class="navigation__link" href="https://oma.media.fi/joroisten-lehti/yhteystiedot/">Yhteystiedot</a></li>
																			</ul>
								</div>
													</div>
					</div>
				</div>
			</li>
			</ul>

	
		</div>
	</div>
</div>




<script>
	(function () {
		if(typeof JankkoSSOClient !== 'undefined'){
			var stringToHTML = function (htmlString) {
				var div = document.createElement('div');
				div.innerHTML = htmlString.trim();
				return div.firstChild;
			};

			var showMenuLinksForLoggedInUser = function(user){
				document.querySelector('#jankko-sso-username').innerHTML = user.first_name+' '+user.last_name;

				var myAccountLink = stringToHTML('<li class="navigation__item "><a class="navigation__link" href="'+JankkoSSOClient.serviceUrls.myAccount+'">Omat tiedot</a></li>');
				var linksElement = document.querySelector('#jankko-sso-links')
				linksElement.insertBefore(myAccountLink, linksElement.childNodes[0]);

				var logoutForm = stringToHTML('<form id="logout-form" action="'+JankkoSSOClient.serviceUrls.logout+'" method="post"><input class="navigation__link" type="submit" value="Kirjaudu ulos"></form>');
				document.querySelector('#jankko-sso-links').appendChild(logoutForm);
			}

			var showMenuLinksForLoggedOutUser = function(data){
				var loginLink = stringToHTML('<li class="navigation__item "><a class="navigation__link" href="/kirjaudu/?returnUrl='+encodeURIComponent(window.location.href.split('?')[0])+'">Kirjaudu</a></li>');
				var linksElement = document.querySelector('#jankko-sso-links')
				linksElement.insertBefore(loginLink, linksElement.childNodes[0]);
			}

			var showCompanyUserRelatedItems = function(data) {
				var permissions = data.company_subscription.permissions;

				if (Array.isArray(permissions)) {
					if (permissions.includes("paywall") || permissions.includes("replica")) {
						document.querySelector('.user--is-not-company-subscriber').classList.replace('user--is-not-company-subscriber', 'user--is-company-subscriber');
					}
				}
			}

			document.addEventListener("DOMContentLoaded", function() {
				JankkoSSOClient.getSession().then(function(data) {
					if (data) {
						if (data.company_subscription) {
							showCompanyUserRelatedItems(data);
						}

						if (data.user) {
							showMenuLinksForLoggedInUser(data.user);
						} else {
							showMenuLinksForLoggedOutUser();
						}
					} else {
						showMenuLinksForLoggedOutUser();
					}
				}).catch(function(error) {
					showMenuLinksForLoggedOutUser();
				});
			});
		}
	}());
</script>

																					                                                            		<div class="display-ad " style="width:0;height:0;margin:0;padding:0;">
		<div class="display-ad__unit advertisement" id="gam-ad-tikkeri">
			<script>if (pageData.gamConfig.enableAds) { googletag.cmd.push(function() { googletag.display('gam-ad-tikkeri'); }); }</script>
		</div>
	</div>

                                                                    		<div class="display-ad " style="width:0;height:0;margin:0;padding:0;">
		<div class="display-ad__unit advertisement" id="gam-ad-interstitiaali">
			<script>if (pageData.gamConfig.enableAds) { if (typeof(document.referrer) === 'string' && document.referrer.indexOf(location.protocol + '//' + location.host) === 0) { googletag.cmd.push(function() { googletag.display('gam-ad-interstitiaali'); }); }}</script>
		</div>
	</div>

    


		
		<div class="layout-container page-container">
							

<div class="header" role="banner"><div class="header__logo-container header__logo-container--narrow">
		<p class="header__logo"><a href="/"><img src="https://a.joroistenlehti.fi/styles/d9ba9ccf/images/logos/joroistenlehti.svg" alt="Joroisten Lehti"></a></p></div>
</div>
<div class="page-notes">
	<div class="note note--promoted hide-on-standalone" >
											<p><a class="note__link" href="/asenna/">Asenna uutissovellus ja päivän lehti</a></p>
			
			</div>
</div>				
						
								
					
																																																																																																																										
			
						
			
											
							
					<div class="display-ad " >
		<div class="display-ad__unit advertisement" id="gam-ad-mobiili1">
			<script>if (pageData.gamConfig.enableAds) { googletag.cmd.push(function() { googletag.display('gam-ad-mobiili1'); }); }</script>
		</div>
	</div>

							
						
								
					
																																																																																																																										
			
						
			
											
							
					<div class="display-ad " >
		<div class="display-ad__unit advertisement" id="gam-ad-paraati1">
			<script>if (pageData.gamConfig.enableAds) { googletag.cmd.push(function() { googletag.display('gam-ad-paraati1'); }); }</script>
		</div>
	</div>

			

			
			<div class="page" role="main" id="sisalto">
				<div class="grid grid--auto">
			<div class="grid__column">
				<div class="article  is--subscriber-only box">
					<div class="layout-inner-container">
						
				
	
<p class="article__meta"><span class="article__section">
			<a class="article__section-link" href="/">Etusivu</a> &raquo;
							<a class="article__section-link" href="https://www.joroistenlehti.fi/urheilu/">Urheilu</a>
					</span><time class="article__published" datetime="2021-09-28T16:30:00+03:00">							28.9.2021 16:30
	</time></p>

		<h1 class="article__headline">Salla Huovinen lopettaa JoU:n pesisnaisten valmentajana</h1>
		
																						
			
	<div class="js-lightgallery">	<figure class="article__featured-image ">
																			
					
												<a class="js-lightgallery__link" href="https://i.media.fi/incoming/vxemqk/7048838.jpg/alternates/FREE_1440/7048838.jpg" data-thumbnail="https://i.media.fi/incoming/vxemqk/7048838.jpg/alternates/FREE_240/7048838.jpg" data-sub-html=" <span class=&quot;figure-info&quot;>Rauno Ylönen</span>">
							<img src="https://i.media.fi/incoming/vxemqk/7048838.jpg/alternates/FREE_720/7048838.jpg" alt="" decoding="sync">
						</a>
						
												</figure>
	</div>

						<div class="before-paywall">
		
		
	
					
														<p>JoU:n naisten suomensarjan pesäpallojoukkuetta viisi vuotta yhteen putkeen luotsannut <strong class="ui-person">Salla Huovinen</strong> lopettaa valmennustehtävät tähän kauteen, joka JoU:n osalta päättyi suomensarjasta maakuntasarjaan putoamiseen.</p>

	</div>
<div class="paywall">
	<div class="paywall__logo">
		<i class="icon icon--large icon--konserni icon--white icon--dot paywall__logo-icon"></i>
	</div>

	<div class="paywall__campaign"><h2 class="paywall__headline">Haluatko lukea koko artikkelin?</h2>									<p>Tilaa digi ja pääset lukemaan kaikki Joroisten Lehden sisällöt.</p>
							<p>											<a class="button " href="https://media.portal.worldoftulo.com/v2/shop/muuri_jorl?utm_source=verkko&amp;utm_medium=maksumuuri&amp;utm_campaign=tilaustarjous&amp;utm_content=jorl_tarjous&amp;accountOrigin=JORL&amp;returnUrl=https%3A%2F%2Fwww.joroistenlehti.fi%2Furheilu%2F4310593&amp;articleid=4310593&amp;cd_source_button=article_paywall&amp;source=maksumuuri_artikkeli">Tilaa 1 kk 1 €</a>
																				<a class="button button--secondary" href="https://media.portal.worldoftulo.com/v2/shop/21pd1jorl?utm_source=verkko&amp;utm_medium=maksumuuri&amp;utm_campaign=tilaustarjous&amp;utm_content=jorl_tarjous&amp;accountOrigin=JORL&amp;returnUrl=https%3A%2F%2Fwww.joroistenlehti.fi%2Furheilu%2F4310593&amp;articleid=4310593&amp;cd_source_button=article_paywall&amp;source=maksumuuri_artikkeli">Tilaa 3 kk 5 €/kk</a>
									<a class="button button--secondary" id="paywall-login-link" href="/kirjaudu/">Olen jo tilaaja</a>
				<script>
					var loginLink = document.querySelector('#paywall-login-link');
					loginLink.href = loginLink.href + "?returnUrl="+encodeURIComponent(window.location.href.split('?')[0]);
				</script></p>
	</div></div>


																																																																																																																																																				
																				

					
							
											
	
<ul class="article-tags">
					<li class="article-tags__tag"><a class="article-tags__tag-link" href="/aihe/Liikunta_ja_urheilu">Liikunta ja urheilu</a></li> 
					<li class="article-tags__tag"><a class="article-tags__tag-link" href="/aihe/Urheilutapahtumat">Urheilutapahtumat</a></li> 
					<li class="article-tags__tag"><a class="article-tags__tag-link" href="/aihe/Pes%C3%A4palloilu">Pesäpalloilu</a></li> 
					<li class="article-tags__tag"><a class="article-tags__tag-link" href="/aihe/Superpesis_Miehet_">Superpesis (Miehet)</a></li> 
					<li class="article-tags__tag"><a class="article-tags__tag-link" href="/aihe/Urheiluvalmennus">Urheiluvalmennus</a></li> 
			</ul>



					</div>
				</div>
				<div class="page-container--inner">							
					
						
								
					
																																																																																																																										
			
						
			
											
							
					<div class="display-ad " >
		<div class="display-ad__unit advertisement" id="gam-ad-jattiboksi1">
			<script>if (pageData.gamConfig.enableAds) { googletag.cmd.push(function() { googletag.display('gam-ad-jattiboksi1'); }); }</script>
		</div>
	</div>

			
									
						
								
					
																																																																																																																										
			
						
			
											
							
					<div class="display-ad " >
		<div class="display-ad__unit advertisement" id="gam-ad-mobiili2">
			<script>if (pageData.gamConfig.enableAds) { googletag.cmd.push(function() { googletag.display('gam-ad-mobiili2'); }); }</script>
		</div>
	</div>

			
				</div>
			</div>
		</div>			</div>
		</div>

						

	<div class="footer" role="contentinfo">
	<div class="layout-container">
					<div class="grid">
				<div class="grid__column footer__main">
											
													<p><img class="footer__main-logo--narrow" src="https://a.joroistenlehti.fi/styles/d9ba9ccf/images/logos/joroistenlehti-white.svg" alt="Joroisten Lehti"></p>
											
											<p>Postiosoite: PL 68, 70101 Kuopio<br>Käyntiosoite: Joroisniementie 4, Joroinen<br>Vastaava päätoimittaja: Sari Ristamäki</p>
									</div>

				<div class="grid__column footer__aside">
											
													<p><a href="https://vastuullistajournalismia.fi/"><img class="footer__aside-logo" src="https://a.joroistenlehti.fi/styles/d9ba9ccf/images/logos/vastuullista-journalismia.png" alt="Vastuullisen journalismin merkki kertoo, että sitä käyttävä media on sitoutunut noudattamaan Julkisen sanan neuvoston laatimia Journalistin ohjeita."></a></p>
											
									</div>
			</div>
		
		<div class="footer__common">
							<p>
					<a class="ui-link" href="https://www.keskisuomalainen.com/">Mediatalo Keskisuomalainen</a>
					&bull; <a class="ui-link" href="https://www.keskisuomalainen.com/tietosuojalauseke">Tietosuojalauseke</a>
											&bull; <a class="ui-link" href="javascript:if(typeof window.__tcfapi !== 'undefined'){window.__tcfapi('displayConsentUi',2,function(){});}else{window.location='https://www.keskisuomalainen.com/tietosuojalauseke';};">Evästevalinnat</a>
									</p>
					</div>
	</div>
</div>




		
								
	<script>
		if (!DOMTokenList.prototype.replace) {
			// IE Polyfill
			DOMTokenList.prototype.replace = function (a, b) {
				if (this.contains(a)) {
						this.add(b);
						this.remove(a);
						return true;
				}
				return false;
			}
		}

		document.querySelector('.no-js').classList.replace('no-js', 'js');

		// User agent sniffing is not reliable and it's going away.
		// Use only to sprinkle a little bit of progressive enhancement on top.
		// Dear Apple, stop lying, iPad on iOS 13 is not a Mac. You're turning into 90s Microsoft.
		var userAgent = navigator.userAgent || navigator.vendor || window.opera;
		if (/android/i.test(userAgent)) {
			document.querySelector('html').classList.add('device__user-agent--android');
		} else if (/iPad|iPhone|iPod/i.test(userAgent) && !window.MSStream) {
			document.querySelector('html').classList.add('device__user-agent--ios');
		} else if (/macintosh/i.test(userAgent) && navigator.maxTouchPoints > 1) {
			document.querySelector('html').classList.add('device__user-agent--ios');
		}
	</script>
	<script>
	// Element.closest() needs a polyfill for older browsers.
	// While we only need the closest() functionality for mobile browsers,
	// we don't want the code to fail even on old desktop browsers.
	// https://developer.mozilla.org/en-US/docs/Web/API/Element/closest#Polyfill
	// https://developer.mozilla.org/en-US/docs/Web/API/Element/closest#Browser_compatibility
	if (!Element.prototype.matches) {
		Element.prototype.matches = Element.prototype.msMatchesSelector || Element.prototype.webkitMatchesSelector;
	}

	if (!Element.prototype.closest) {
		Element.prototype.closest = function(s) {
			var el = this;

			do {
				if (el.matches(s)) return el;
				el = el.parentElement || el.parentNode;
			} while (el !== null && el.nodeType === 1);
			return null;
		};
	}

	// Navigation dropdown
	// This progressive enhancement:
	// 1) Toggles desired DOM element, making sure only one is open at a time
	// 2) On small screens ensures the dropdown is always scrollable by:
	//    - Making .navbar the full height of the screen
	//    - Preventing scrolling the body content underneath
	document.querySelectorAll('.navbar .js-toggler').forEach(function(toggler) {
		var target = document.getElementById(toggler.getAttribute('data-toggle'));
		if (target) {
			toggler.addEventListener('click', function(e) {
				e.preventDefault();

				if (window.getComputedStyle(target).display === 'block') {
					// This toggle is open

					// Close this toggle
					target.classList.remove('navbar__dropdown--is-open');

					// Remove .navbar--is-open from parent .navbar (and possible .navbar--is-fullsized)
					target.closest('.navbar').classList.remove('navbar--is-open', 'navbar--is-fullsized');

					// Remove .ui-prevent-scroll from body on smaller screens (and possibly from larger as well)
					document.querySelector('body').classList.remove('ui-prevent-scroll--on-smaller-screens', 'ui-prevent-scroll');
				} else {
					// This toggle is closed

					// If other toggles are open, close them
					document.querySelectorAll('.navbar__dropdown--is-open').forEach(function(item) {
						item.classList.remove('navbar__dropdown--is-open');
					});

					// Open this toggle
					target.classList.add('navbar__dropdown--is-open');

					// Add .navbar--is-open to parent .navbar
					target.closest('.navbar').classList.add('navbar--is-open');

					// Add .ui-prevent-scroll to body on smaller screens
					document.querySelector('body').classList.add('ui-prevent-scroll--on-smaller-screens');

					// Make sure navigation is never larger than screen
					if ((target.offsetHeight + target.closest('.navbar').offsetHeight) >= window.innerHeight) {
						target.closest('.navbar').classList.add('navbar--is-fullsized');
						document.querySelector('body').classList.add('ui-prevent-scroll');
					}
				}
			});
		}
	});

	// Fixed navbar is a js-only functionality (because padding depends on height, which is not static)
	document.querySelectorAll('.navbar--fixed').forEach(function(item) {
		item.classList.add('navbar--is-fixed');
		item.parentNode.style.paddingTop = item.offsetHeight + 'px';
	});

	// Set main fixed navbar height to a CSS variable to make anchor links work perfectly
	var mainFixedNavbar = document.querySelector('.navbar.navbar--is-fixed');
	if (mainFixedNavbar) {
		var mainFixedNavbarHeightWithOffset = mainFixedNavbar.offsetHeight + 10;
		document.documentElement.style.setProperty('--fixed-navbar-height', mainFixedNavbarHeightWithOffset + 'px');
	}
</script>

	<script src="/theme/css/includes/waypoints/lib/noframework.waypoints.min.js"></script>
	<script>
		// A simple Waypoints navbar content switcher (Sisältö/Takaisin)
		var waypointNavbarPrimary = document.querySelector('.js-waypoint-navbar-primary');
		var waypointNavbarSecondary = document.querySelector('.js-waypoint-navbar-secondary');

		if (waypointNavbarPrimary && waypointNavbarSecondary) {
			var waypointNavbar = new Waypoint({
				element: document.getElementById('sisalto'),
				handler: function() {
					if (window.getComputedStyle(waypointNavbarPrimary).display === 'block') {
						waypointNavbarPrimary.style.display = 'none';
						waypointNavbarSecondary.style.display = 'block';
					} else {
						waypointNavbarPrimary.style.display = 'block';
						waypointNavbarSecondary.style.display = 'none';
					}
				},
				offset: mainFixedNavbarHeightWithOffset
			});
		}

		// Super duper awesome link back/home
		document.querySelectorAll('a.js-link-back-or-home').forEach(function(item) {
			// Referrer supports new tab/window and provides visual cue.
			// Note: referrer isn't always available (browser, tab, window, bookmark, privacy).
			if (typeof(document.referrer) === 'string' && document.referrer.length > 0) {
				item.setAttribute('href', document.referrer);
			}

			// Overwrite link with history.go, as it also remembers scroll position
			if (history.length > 1) {
				var stepsToGoBack = -1;

				// Ignore in-page hash navigation when going back (crude version)
				window.onhashchange = function() {
					if (location.hash === "#kommentit") {
						stepsToGoBack = -2;
					}
				}

				item.addEventListener('click', function(e) {
					e.preventDefault();
					history.go(stepsToGoBack); // history.go(-1) == history.back()
				});
			}
		});

	</script>

	<script>
	// Show more
	// This progressive enhancement:
	// 1) Activates the target of all .show-more__reveal links with a class.
	// 2) Removes pointless functionality if target element doesn't exist.
	document.querySelectorAll('.show-more__reveal').forEach(function(link) {
		var target = document.getElementById(link.href.split('#')[1]);
		if (target) {
			link.addEventListener('click', function(e) {
				target.classList.add('show-more__target--js-activated');
				e.preventDefault();
			});
		} else {
			// Graceful mode removes reveal functionality
			link.parentNode.classList.add('show-more__reveal-container--is-broken');

			// Hardcore mode removes all links
			// link.parentElement.style.display = 'none';
		}
	});
</script>


	<script>
		// Service Worker
		if ('serviceWorker' in navigator) {
			window.addEventListener('load', function() {
				navigator.serviceWorker.register('/sw.js').then(
					function(registration) {
						console.log('PWA: Service worker registered to scope: ', registration.scope);
					},
					function(err) {
						console.error('PWA: Service worker failed to register with error: ', err);
					}
				);
			});
		}
	</script>

	<link rel="stylesheet" href="/theme/css/includes/lightgallery/css/lightgallery.min.css">
<script src="/theme/css/includes/lightgallery/js/lightgallery.min.js"></script>
<script src="/theme/css/includes/lightgallery/js/lg-autoplay.min.js"></script>
<script src="/theme/css/includes/lightgallery/js/lg-fullscreen.min.js"></script>
<script src="/theme/css/includes/lightgallery/js/lg-thumbnail.min.js"></script>
<script src="/theme/css/includes/lightgallery/js/lg-zoom.min.js"></script>


	<script>
	// lightGallery
	// Separate gallery for every .js-lightgallery
	// Gallery items come from .js-lightgallery .js-lightgallery__link
	// https://sachinchoolur.github.io/lightgallery.js/docs/api.html
	document.querySelectorAll('.js-lightgallery').forEach(function(gallery) {
		// Thumbnails come from img inside the links, unless links specify data-thumbnail
		var thumbnailSource = (gallery.getElementsByClassName('js-lightgallery__link')[0].hasAttribute('data-thumbnail')) ? ('data-thumbnail') : (false);

		// Initialize
		lightGallery(gallery, {
			actualSize: false, // Enable actual pixel icon
			download: false, // Enable download button
			hideControlOnEnd: true, // Hide prev/next button on first/last image
			loop: false, // Ability to loop back to beginning from last element
			exThumbImage: thumbnailSource,
			selector: '.js-lightgallery__link' // Custom selector instead of just child
		});
	});
</script>




			

			
						</body>
</html>
