
<!doctype html>
<html class="diks-no-js diks-site--joroistenlehti diks-user--is-not-logged-in diks-user--is-not-subscriber diks-user--is-not-company-subscriber diks-site--layout-master" lang="fi" prefix="og: http://ogp.me/ns#">
	<head>
		<meta charset="utf-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		<title>Kukkakauppa palasi Varkauden Forumiin: Nuppu&amp;Silmu laajensi Joroisista | Paikalliset | Joroisten Lehti</title>
		<link rel="stylesheet" href="https://a.joroistenlehti.fi/styles/9d7423e4/styles/diks-news.css">

		
		

		<link rel="manifest" href="/manifest.webmanifest">
		<script>
		window.Hyphenopoly = {
			require: {
				"fi": "yhdyssanahirviö"
			},
			setup: {
				selectors: {".diks-card__title": {}}
			}
		};
	</script>

	<script src="https://a.joroistenlehti.fi/styles/9d7423e4/includes/hyphenopoly/Hyphenopoly_Loader.js"></script>
			<script>
		window.JankkoSSOConfig = {
			accountOrigin: "JORL"
		};
  </script>

	<script id="jankko-sso-script" src="https://sso.joroistenlehti.fi/assets/jankko-sso-client.min.js"></script>
	
		<script src='/gravito_config.js'></script>
		<link rel="apple-touch-icon" href="/icon-512.png">
	<link rel="apple-touch-icon" sizes="512x512" href="/icon-512.png">
	<link rel="apple-touch-icon" sizes="256x256" href="/icon-256.png"><link rel="apple-touch-startup-image" href="/iphone5_splash.png" media="(device-width: 320px) and (device-height: 568px) and (-webkit-device-pixel-ratio: 2)">
	<link rel="apple-touch-startup-image" href="/iphone6_splash.png" media="(device-width: 375px) and (device-height: 667px) and (-webkit-device-pixel-ratio: 2)">
	<link rel="apple-touch-startup-image" href="/iphoneplus_splash.png" media="(device-width: 621px) and (device-height: 1104px) and (-webkit-device-pixel-ratio: 3)">
	<link rel="apple-touch-startup-image" href="/iphonex_splash.png" media="(device-width: 375px) and (device-height: 812px) and (-webkit-device-pixel-ratio: 3)">
	<link rel="apple-touch-startup-image" href="/iphonexr_splash.png" media="(device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 2)">
	<link rel="apple-touch-startup-image" href="/iphonexsmax_splash.png" media="(device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 3)">
	<link rel="apple-touch-startup-image" href="/ipad_splash.png" media="(device-width: 768px) and (device-height: 1024px) and (-webkit-device-pixel-ratio: 2)">
	<link rel="apple-touch-startup-image" href="/ipadpro1_splash.png" media="(device-width: 834px) and (device-height: 1112px) and (-webkit-device-pixel-ratio: 2)">
	<link rel="apple-touch-startup-image" href="/ipadpro3_splash.png" media="(device-width: 834px) and (device-height: 1194px) and (-webkit-device-pixel-ratio: 2)">
	<link rel="apple-touch-startup-image" href="/ipadpro2_splash.png" media="(device-width: 1024px) and (device-height: 1366px) and (-webkit-device-pixel-ratio: 2)"><link rel="alternate" type="application/rss+xml" title="Joroisten Lehti" href="https://www.joroistenlehti.fi/feed/rss"><meta name="facebook-domain-verification" content="4xtdxvaklxywo753n2rjnzack7p2st"><script>
	var pageData = {};
	pageData.article = {
			'id':'4695482',
			'url':'https\u003A\/\/www.joroistenlehti.fi\/paikalliset\/4695482',
			'published': '2022\u002D06\u002D28\u002010\u003A41',
			'modified': '2022\u002D06\u002D28\u002010\u003A46',
			'storyType':'story',
			'paywall':'paid',
			'headlinePrefix':'',
			'headline':'Kukkakauppa\u0020palasi\u0020Varkauden\u0020Forumiin\u003A\u0020Nuppu\u0026Silmu\u0020laajensi\u0020Joroisista',
			'lead':'',
			'description':'',
			'priority':'default',
			'style':'default',
			'brandSafety':'1',
			'brandSafetyScore':'0.99937',
			'mainImage':'https://i.media.fi/incoming/m1n44g/8073375.jpg/alternates/FREE_960/8073375.jpg',
			'teaserImage':'',
			'authors': ['Eelis\u0020Berglund'],
			'topics': ["Tekstiilit","Vaatekappaleet","keng\u00e4t ja asusteet","Koti ja asuminen","Perhe","Kulutustavarat","Sisustaminen","Lapset","Juhla- ja vapaap\u00e4iv\u00e4t","Ostosten tekeminen","Lapset ja nuoret","El\u00e4m\u00e4ntapa ja vapaa-aika","V\u00e4hitt\u00e4iskauppa pl. moottoriajoneuvot; kotitaloustavaroiden korjaus"],
			'marketingCategories': ["Tapahtumat","Kulttuuri","Yritykset","Viihde","Kotimaa","Talous"],
			'elementCount': 16,
			'contentLength': 2558,
			'imageCount': 1
		}
	pageData.section = {
			'name': 'Paikalliset',
			'uname': 'paikalliset',
			'url': 'https\u003A\/\/www.joroistenlehti.fi\/paikalliset\/'
		}
	pageData.publication = {
		'name': 'joroistenlehti',
		'url': 'https\u003A\/\/www.joroistenlehti.fi\/',
		'engage': 'JORL',
		'paywallEnabled': true,
		'env':'prod'
	}
	pageData.user = {}
	pageData.companyUser = {}

	function isPwa() {
		// window.navigator.standalone = iOS
		// window.matchMedia('(display-mode: standalone)').matches = Android/universal
		return (window.navigator.standalone) ||
		       (["fullscreen", "standalone", "minimal-ui"].some(
		        function(displayMode) { return window.matchMedia('(display-mode: ' + displayMode + ')')
		        .matches }));
	}

	pageData.general = {
		'browseMode': (isPwa() ? 'pwa' : 'browser')
	}
</script>
	<meta property="og:site_name" content="Joroisten Lehti">
	<meta property="og:locale" content="fi_FI">


<link rel="canonical" href="https://www.warkaudenlehti.fi/paikalliset/4695482" />
<meta property="og:url" content="https://www.joroistenlehti.fi/paikalliset/4695482" />
<meta name="description" content="Varkauteen uuden kukka- ja sisustusliikkeen avannut Suvi Riekkinen on työskennellyt kauppakeskus Forumissa jo lähes kuukauden ajan." />
<meta name="keywords" content="Tekstiilit, Vaatekappaleet, kengät ja asusteet, Koti ja asuminen, Perhe, Kulutustavarat, Sisustaminen" />
	<meta property="og:title" content="Kukkakauppa palasi Varkauden Forumiin: Nuppu&amp;Silmu laajensi Joroisista" />
<meta property="og:description" content="Varkauteen uuden kukka- ja sisustusliikkeen avannut Suvi Riekkinen on työskennellyt kauppakeskus Forumissa jo lähes kuukauden ajan." />
<meta property="og:image" content="https://i.media.fi/incoming/m1n44g/8073375.jpg/alternates/LANDSCAPE_960/8073375.jpg" />
<meta property="og:image:width" content="960" />
<meta property="og:image:height" content="640" />
<meta property="og:type" content="article" />
<meta property="article:author" content="Eelis Berglund" />
<meta property="article:section" content="Paikalliset" />
<meta property="article:tag" content="Tekstiilit" />
<meta property="article:tag" content="Vaatekappaleet" />
<meta property="article:tag" content="kengät ja asusteet" />
<meta property="article:tag" content="Koti ja asuminen" />
<meta property="article:tag" content="Perhe" />
<meta property="article:tag" content="Kulutustavarat" />
<meta property="article:tag" content="Sisustaminen" />
<meta property="article:modified_time" content="2022-06-28T10:46:44+03:00" />
<meta property="article:published_time" content="2022-06-28T10:41:44+03:00" />


<meta name="cXenseParse:recs:recommendable" content="true"/>
<meta name="cXenseParse:pageclass" content="article"/>
<meta name="cXenseParse:recs:articleid" content="4695482" />
<meta name="cXenseParse:recs:kes-origin" content="Warkauden Lehti" />
<meta name="cXenseParse:kes-origin" content="Warkauden Lehti" />
<meta name="cXenseParse:recs:kes-isad" content="false" />
<meta name="cXenseParse:kes-isad" content="false" />
<meta name="cXenseParse:recs:kes-hasimage" content="true" />
<meta name="cXenseParse:kes-hasimage" content="true" />
<meta name="cXenseParse:recs:kes-source" content="Warkauden Lehti" />
<meta name="cXenseParse:kes-source" content="Warkauden Lehti" />
<meta name="cXenseParse:recs:kes-articletype" content="Story" />
<meta name="cXenseParse:kes-articletype" content="Story" />
<meta name="cXenseParse:recs:kes-siterecsname" content="Joroisten Lehti" />
<meta name="cXenseParse:recs:kes-keywordtag" content="Tekstiilit" />
<meta name="cXenseParse:kes-keywordtag" content="Tekstiilit" />
<meta name="cXenseParse:recs:kes-keywordtag" content="Vaatekappaleet" />
<meta name="cXenseParse:kes-keywordtag" content="Vaatekappaleet" />
<meta name="cXenseParse:recs:kes-keywordtag" content="kengät ja asusteet" />
<meta name="cXenseParse:kes-keywordtag" content="kengät ja asusteet" />
<meta name="cXenseParse:recs:kes-keywordtag" content="Koti ja asuminen" />
<meta name="cXenseParse:kes-keywordtag" content="Koti ja asuminen" />
<meta name="cXenseParse:recs:kes-keywordtag" content="Perhe" />
<meta name="cXenseParse:kes-keywordtag" content="Perhe" />
<meta name="cXenseParse:recs:kes-keywordtag" content="Kulutustavarat" />
<meta name="cXenseParse:kes-keywordtag" content="Kulutustavarat" />
<meta name="cXenseParse:recs:kes-keywordtag" content="Sisustaminen" />
<meta name="cXenseParse:kes-keywordtag" content="Sisustaminen" />
<meta name="cXenseParse:recs:publishtime" content="2022-06-28T10:41:44+03:00" />
<meta name="cXenseParse:kes-paywall" content="paid" />
<meta name="cXenseParse:recs:kes-paywall" content="paid" />
<meta name="cXenseParse:kes-storyType" content="story" />
<meta name="cXenseParse:recs:kes-storyType" content="story" />
<meta name="cXenseParse:kes-priority" content="default" />
<meta name="cXenseParse:recs:kes-priority" content="default" />
<meta name="cXenseParse:kes-style" content="default" />
<meta name="cXenseParse:recs:kes-style" content="default" />
<meta name="cXenseParse:kes-template" content="default" />
<meta name="cXenseParse:recs:kes-template" content="default" />

		
		<script async='async' src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script><script>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</script>
		<script>
		initTagManager = (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
		})(window,document,'script','dataLayer','GTM-KTJNB7R');

		var dataLayer = window.dataLayer || [];
		window.dataLayer.push({'event':'pageDataPush','pageData': window.pageData});
		window.initTagManager;

		(function () {
			var user = {};
			var companyUser = {};
			var articleState;
			var paywallEnabled = (typeof window.pageData.publication.paywallEnabled !== undefined) ? window.pageData.publication.paywallEnabled : true;

							// free is always the safer fallback
				var articlePaywall = "free";

				if (window.pageData && window.pageData.article && window.pageData.article.paywall) {
					articlePaywall = window.pageData.article.paywall;
				}

				if (articlePaywall == "free" || !paywallEnabled) {
					articleState = "full";
				}
				else {
					articleState = "preview";
				}
			
			function getCookie(name) {
				name = name + '=';
				const decodedCookie = decodeURIComponent(document.cookie);
				const cookies = decodedCookie.split(';');

				for (let i = 0; i < cookies.length; i++) {
					const cookie = cookies[i].trim();
					if (cookie.indexOf(name) == 0) {
						return cookie.substring(name.length, cookie.length);
					}
				}
			}

			function pushDataLayerEvent() {
				let segmentsCookie = getCookie('jankkosegments');

				if (segmentsCookie) {
					let segmentsData = JSON.parse(segmentsCookie);
					let segments = segmentsData.segments;

					if (segments && typeof segments === 'object') {
						user.segments = segments;
					}
				}

				window.dataLayer.push({'event': 'userDataPush',
					'pageData': {
											'article': {
						'state': articleState
						},
											'user': user,
						'companyUser': companyUser
					}
				});
			}

			if (typeof JankkoSSOClient !== 'undefined') {
				JankkoSSOClient.getSession().then(function(data) {
					if (data) {
						user.id = data.user ? data.user.id : undefined;
						user.products = data.active_products;
						user.permissions = data.permissions;

						if (data.company_subscription) {
							companyUser.id = data.company_subscription.user ? data.company_subscription.user.id : undefined;
							companyUser.products = data.company_subscription.active_products;
							companyUser.permissions = data.company_subscription.permissions;
						}

						var tuloUserPermissions = Array.isArray(user.permissions) ? user.permissions : [];
						var companyUserPermissions = Array.isArray(companyUser.permissions) ? companyUser.permissions : [];

						var permissions = tuloUserPermissions.concat(companyUserPermissions);

													if (articlePaywall != "free" && permissions.includes("paywall")) {
								articleState = "full";
							}
											}

					pushDataLayerEvent();
				})
				.catch(function(error) {
					console.log(error);
					pushDataLayerEvent();
				});
			}
			else {
				pushDataLayerEvent();
			}
		}());

	</script>
	</head>
	<body class="diks-body">
		<!-- Google Tag Manager (noscript) -->
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KTJNB7R"
        height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <!-- End Google Tag Manager (noscript) -->
					<div class="diks-display-ad ">
		<div class="diks-display-ad__unit" id="gam-ad-tikkeri" style="width:0;height:0;margin:0;padding:0;">
			<script>googletag.cmd.push(function() { googletag.display('gam-ad-tikkeri'); });</script>
		</div>
	</div><div class="diks-display-ad ">
		<div class="diks-display-ad__unit" id="gam-ad-interstitiaali" style="width:0;height:0;margin:0;padding:0;">
			<script>googletag.cmd.push(function() { googletag.display('gam-ad-interstitiaali'); });</script>
		</div>
	</div>
		
					
		
																				
																							
																								
																								
																								
																								
							<header class="diks-header diks-header--is-fixed">
	<div class="diks-container">
		<div class="diks-header-container">
			<div class="diks-header__logo-container">
				<a class="diks-logo__link" href="/"><img src="https://a.joroistenlehti.fi/styles/9d7423e4/images/logos/joroistenlehti.svg" class="diks-logo diks-header__logo" alt="Joroisten Lehti"></a>
			</div><div class="diks-header__navigation-container">
					<nav class="diks-navigation-wrapper " >
		<ul class="diks-navigation diks-navigation--row diks-navigation--hide-on-mobile diks-navigation--color-primary diks-navigation--size-s" ><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/asenna/">Sovellukset</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/nakoislehti/">Näköislehti</a>
					</li><li class="diks-navigation__item diks-navigation__item--button diks-hide-from-subscribers" >
						<a class="diks-navigation__link" href="/tilaa/">Tilaa</a>
					</li><li class="diks-navigation__item js-diks-toggler js-diks-user-toggler"  id="diks-sso-user" data-diks-toggle="diks-user-navigation" data-diks-toggle-class="diks-user-navigation">
						<a class="diks-navigation__link" href="#tili"><span class="diks-icon diks-icon--size-m" aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path fill-rule="evenodd" d="M12 4C10.3431 4 9 5.34315 9 7C9 8.65685 10.3431 10 12 10C13.6569 10 15 8.65685 15 7C15 5.34315 13.6569 4 12 4ZM7 7C7 4.23858 9.23858 2 12 2C14.7614 2 17 4.23858 17 7C17 9.76142 14.7614 12 12 12C9.23858 12 7 9.76142 7 7ZM6.12368 18.9993H17.8763C17.3288 16.8024 15.0162 15 12 15C8.98382 15 6.67122 16.8024 6.12368 18.9993ZM4 19.9993C4 15.9945 7.73202 13 12 13C16.268 13 20 15.9945 20 19.9993V20.9993H4V19.9993Z" clip-rule="evenodd"/>
</svg>
</span>Tili</a>
					</li><li class="diks-navigation__item diks-dropdown-toggler"  id="diks-dropdown-toggle" data-toggle="diks-dropdown-navigation">
						<a class="diks-navigation__link" href="#valikko"><span class="diks-icon diks-icon--size-m" aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path fill-rule="evenodd" d="M22 6H2V4H22V6ZM22 13H2V11H22V13ZM22 20H2V18H22V20Z" clip-rule="evenodd"/>
</svg>
</span><span class="diks-icon diks-icon--size-m diks-icon--hidden" aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path fill-rule="evenodd" d="M10.5858 12L4.2218 5.63603L5.63602 4.22182L12 10.5858L18.3639 4.22183L19.7782 5.63605L13.4142 12L19.7782 18.364L18.3639 19.7782L12 13.4142L5.63602 19.7782L4.2218 18.364L10.5858 12Z" clip-rule="evenodd"/>
</svg>
</span>Valikko</a>
					</li></ul>
	</nav><div id="diks-dropdown-mobile-toggler" class="diks-dropdown-toggler diks-dropdown-mobile-toggler" data-toggle="diks-dropdown-navigation">
			<span class="diks-icon diks-icon--color-primary" aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path fill-rule="evenodd" d="M22 6H2V4H22V6ZM22 13H2V11H22V13ZM22 20H2V18H22V20Z" clip-rule="evenodd"/>
</svg>
</span>
			<span class="diks-icon diks-icon--color-primary diks-icon--hidden" aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path fill-rule="evenodd" d="M10.5858 12L4.2218 5.63603L5.63602 4.22182L12 10.5858L18.3639 4.22183L19.7782 5.63605L13.4142 12L19.7782 18.364L18.3639 19.7782L12 13.4142L5.63602 19.7782L4.2218 18.364L10.5858 12Z" clip-rule="evenodd"/>
</svg>
</span>
		</div>

		<div class="diks-dropdown-navigation" id="diks-dropdown-navigation"><form id="dropdown-navigation-search" name="dropdownnavigationsearch" class="diks-form diks-form--fluid" action="/haku/" method="get">
					<div class="diks-form__field-wrapper  diks-form__field-wrapper--required">			<div class="diks-form__icon-field-wrapper"><input class="diks-form__field" type="search" name="q" id="dropdown-navigation-searchSearch1" size="20" required placeholder="Etsi sivustolta" value=""><span class="diks-icon diks-icon--color-weak" aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path fill-rule="evenodd" d="M9.5 4C6.46243 4 4 6.46243 4 9.5C4 12.5376 6.46243 15 9.5 15C12.5376 15 15 12.5376 15 9.5C15 6.46243 12.5376 4 9.5 4ZM2 9.5C2 5.35786 5.35786 2 9.5 2C13.6421 2 17 5.35786 17 9.5C17 11.2106 16.4273 12.7874 15.4632 14.0493L19.7782 18.3642L18.3639 19.7784L14.049 15.4634C12.7872 16.4274 11.2105 17 9.5 17C5.35786 17 2 13.6421 2 9.5Z" clip-rule="evenodd"/>
</svg>
</span></div></div>

						<div class="diks-form__field-wrapper diks-form__field-wrapper--replace-icon">
		<input class="diks-form__submit" type="submit" id="dropdown-navigation-searchSubmit2" value="Hae">
	</div>
			</form><nav class="diks-navigation-wrapper diks-navigation-wrapper--border-bottom diks-navigation-wrapper--border-top" >
		<ul class="diks-navigation diks-navigation--row diks-navigation--mobile-row diks-navigation--color-primary diks-navigation--size-s"  id="dropdown-highlights-nav"><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/asenna/">Sovellukset</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/nakoislehti/">Näköislehti</a>
					</li><li class="diks-navigation__item diks-navigation__item--button diks-navigation__item--align-right diks-hide-from-subscribers" >
						<a class="diks-navigation__link" href="/tilaa/">Tilaa</a>
					</li></ul>
	</nav><nav class="diks-navigation-wrapper " >
		<ul class="diks-navigation "  id="dropdown-section-nav"><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/">Etusivu</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/uusimmat/">Uusimmat</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/luetuimmat/">Luetuimmat</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/paikalliset/">Paikalliset</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/urheilu/">Urheilu</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/paakirjoitus-mielipide/">Pääkirjoitus &amp; mielipide</a>
					</li></ul>
	</nav><!-- ESI start element "recommendedTopics" generated at 28-06-2022 21:08:04.534882 --><!-- ESI end element "recommendedTopics" --><nav class="diks-navigation-wrapper diks-navigation-wrapper--divider-top" >
		<ul class="diks-navigation diks-navigation--light diks-navigation--size-s"  id="dropdown-customer-nav"><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="https://oma.media.fi/joroisten-lehti/">Asiakaspalvelu</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="https://www.meks.fi/mainonta/alueet/savon-media/">Mediamyynti</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="https://oma.media.fi/joroisten-lehti/yhteystiedot/">Yhteystiedot</a>
					</li></ul>
	</nav></div><script>
	// Fix forEach for IE
	if (window.NodeList && !NodeList.prototype.forEach) {
		NodeList.prototype.forEach = Array.prototype.forEach;
	}

	// Element.closest() needs a polyfill for older browsers.
	// While we only need the closest() functionality for mobile browsers,
	// we don't want the code to fail even on old desktop browsers.
	// https://developer.mozilla.org/en-US/docs/Web/API/Element/closest#Polyfill
	// https://developer.mozilla.org/en-US/docs/Web/API/Element/closest#Browser_compatibility
	if (!Element.prototype.matches) {
		Element.prototype.matches = Element.prototype.msMatchesSelector || Element.prototype.webkitMatchesSelector;
	}

	if (!Element.prototype.closest) {
		Element.prototype.closest = function(s) {
			var el = this;

			do {
				if (el.matches(s)) return el;
				el = el.parentElement || el.parentNode;
			} while (el !== null && el.nodeType === 1);
			return null;
		};
	}

	// Navigation dropdown
	document.querySelectorAll('.diks-dropdown-toggler').forEach(function(toggler) {
		var target = document.getElementById(toggler.getAttribute('data-toggle'));
		if (target) {
			toggler.addEventListener('click', function(e) {
				e.preventDefault();

				if (window.getComputedStyle(target).display === 'block') {
					// This toggle is open

					// Close this toggle
					target.classList.remove('diks-dropdown-navigation--is-open');
					toggler.classList.remove('diks-dropdown-toggler--is-open');

					// Toggle icon
					children = toggler.querySelectorAll('.diks-icon');
					if ( children.length > 1 ) {
						for (var j= 0; j < children.length; j++){
							children[j].classList.toggle('diks-icon--hidden');
						}
					}

					// Remove is-open class from body
					document.body.classList.remove('diks-body--dropdown-navigation-is-open');

					// Turn off shade effect
					document.querySelector('.diks-dropdown-navigation-shade').classList.remove('diks-dropdown-navigation-shade--is-visible');
				}
				else {
					// If other toggles are open, close them
					document.querySelectorAll('.diks-dropdown-navigation--is-open').forEach(function(item) {
						item.classList.remove('diks-dropdown-navigation--is-open');
						toggler.classList.remove('diks-dropdown-toggler--is-open');
					});
					// Close user nav when main dropdown nav is opened
					document.getElementById('diks-user-navigation').classList.remove('diks-user-navigation--is-open');

					// Open this toggle
					target.classList.add('diks-dropdown-navigation--is-open');

					// Add .diks-dropdown-navigation--is-open to parent .diks-dropdown-navigation
					target.closest('.diks-dropdown-navigation').classList.add('diks-dropdown-navigation--is-open');

					// Toggle icon
					toggler.classList.add('diks-dropdown-toggler--is-open');
					children = toggler.querySelectorAll('.diks-icon');
					if ( children.length > 1 ) {
						for (var j= 0; j < children.length; j++){
							children[j].classList.toggle('diks-icon--hidden');
						}
					}

					// Add is-open class to body
					document.body.classList.add('diks-body--dropdown-navigation-is-open');

					// Turn on shade effect
					document.querySelector('.diks-dropdown-navigation-shade').classList.add('diks-dropdown-navigation-shade--is-visible');
				}
			});
		}
	});
</script>
				</div></div><a id="diks-sso-user-mobile" href="#tili" class="diks-mobile-toggler diks-mobile-toggler--user js-diks-toggler js-diks-user-toggler" data-diks-toggle="diks-user-navigation" data-diks-toggle-class="diks-user-navigation"><span class="diks-icon diks-icon--color-primary" aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path fill-rule="evenodd" d="M12 4C10.3431 4 9 5.34315 9 7C9 8.65685 10.3431 10 12 10C13.6569 10 15 8.65685 15 7C15 5.34315 13.6569 4 12 4ZM7 7C7 4.23858 9.23858 2 12 2C14.7614 2 17 4.23858 17 7C17 9.76142 14.7614 12 12 12C9.23858 12 7 9.76142 7 7ZM6.12368 18.9993H17.8763C17.3288 16.8024 15.0162 15 12 15C8.98382 15 6.67122 16.8024 6.12368 18.9993ZM4 19.9993C4 15.9945 7.73202 13 12 13C16.268 13 20 15.9945 20 19.9993V20.9993H4V19.9993Z" clip-rule="evenodd"/>
</svg>
</span></a>

			<div id="diks-user-navigation" class="diks-user-navigation">
				<p id="diks-sso-username" class="diks-user-navigation__username diks-hide-from-company-subscribers"></p><p class="diks-user-navigation__username diks-show-for-company-subscribers">Yritystilaus tunnistettu</p><div class="diks-show-for-company-subscribers"><p>Voit käyttää palvelun kaikkia sisältöjä vapaasti. Jos haluat kommentoida, kirjaudu sisään henkilökohtaisella Mediatunnuksella.</p></div><nav class="diks-navigation-wrapper diks-user-navigation__dropdown" >
		<ul class="diks-navigation "  id="diks-sso-links"><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="javascript:window.gravitoCMP.openPreferences();">Evästevalinnat</a>
					</li></ul>
	</nav>
			</div><div class="diks-pwa-back-navigation__wrapper diks-show-on-standalone">
				<div class="diks-pwa-back-navigation">
					<a class="diks-pwa-back-navigation__link js-diks-back-button" href="/"><span class="diks-icon " aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path fill-rule="evenodd" d="M11.707 5.70711L10.2928 4.29289L2.58569 12L10.2928 19.7071L11.707 18.2929L6.41412 13L20 13V11L6.41412 11L11.707 5.70711Z" clip-rule="evenodd"/>
</svg>
</span> <span class="diks-pwa-back-navigation__text">Takaisin</span></a>
				</div>
			</div></div>
</header><div id="diks-dropdown-navigation-shade" class="diks-dropdown-navigation-shade"></div><div class="diks-section-navigation-wrapper">
		<div class="diks-container">
			<nav class="diks-navigation-wrapper " >
		<ul class="diks-navigation diks-navigation--row diks-navigation--size-s"  id="osastovalikko"><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/">Etusivu</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/uusimmat/">Uusimmat</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/luetuimmat/">Luetuimmat</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/paikalliset/">Paikalliset</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/urheilu/">Urheilu</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/paakirjoitus-mielipide/">Pääkirjoitus &amp; mielipide</a>
					</li></ul>
	</nav>
		</div>
	</div><div class="diks-mobile-highlighted-navigation-wrapper">
		<div class="diks-container">
			<nav class="diks-navigation-wrapper " >
		<ul class="diks-navigation diks-navigation--row diks-navigation--mobile-row diks-navigation--color-primary diks-navigation--size-s"  id="dropdown-highlights-nav-mobile"><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/asenna/">Sovellukset</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/nakoislehti/">Näköislehti</a>
					</li><li class="diks-navigation__item diks-navigation__item--button diks-navigation__item--align-right diks-hide-from-subscribers" >
						<a class="diks-navigation__link" href="/tilaa/">Tilaa</a>
					</li></ul>
	</nav>
		</div>
	</div><div class="diks-note-wrapper"><div id="diks-segment-notes"></div></div><script>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</script>

		
		<div id="sisalto" role="main">
				<div class="diks-display-ad ">
		<div class="diks-display-ad__unit" id="gam-ad-paraati1" >
			<script>googletag.cmd.push(function() { googletag.display('gam-ad-paraati1'); });</script>
		</div>
	</div>
	<div class="diks-container">
		<div class="diks-grid diks-article ">
			<div class="diks-column diks-column--l-span-1 diks-column--xl-span-3"></div>
			<div class="diks-column diks-column--span-4 diks-column--m-span-8 diks-column--l-span-10 diks-column--xl-span-10">
				<div class="diks-meta diks-top-meta">
					<nav>
		<ul class="diks-breadcrumb"><li class="diks-breadcrumb__item"><a class="diks-breadcrumb__link" href="/">Etusivu</a></li><li class="diks-breadcrumb__item"><a class="diks-breadcrumb__link" href="https://www.joroistenlehti.fi/paikalliset/">Paikalliset</a></li></ul>
	</nav><span class="diks-article__tag diks-article__tag--subscribers-only">Vain tilaajille</span></div>
			</div>
		</div>
		<div class="diks-article-top "><div class="diks-grid diks-article ">
					<div class="diks-column diks-column--l-span-1 diks-column--xl-span-3"></div>
					<div class="diks-column diks-column--span-4 diks-column--m-span-8 diks-column--l-span-10 diks-column--xl-span-10">
						<h1 class="diks-article__headline">Kukkakauppa palasi Varkauden Forumiin: Nuppu&amp;Silmu laajensi Joroisista</h1>
					</div>
				</div><div class="diks-grid diks-article ">
					<div class="diks-column diks-column--xl-span-1"></div>
					<div class="diks-column diks-column--span-4 diks-column--m-span-8 diks-column--l-span-12 diks-column--xl-span-14"><figure class="diks-figure diks-figure--featured">
		<a class="diks-gallery__link" href="https://i.media.fi/incoming/m1n44g/8073375.jpg/alternates/FREE_1440/8073375.jpg" data-thumbnail="https://i.media.fi/incoming/m1n44g/8073375.jpg/alternates/SQUARE_240/8073375.jpg" data-sub-html="Sara Riekkinen iloitsee, että varkautelaiset ovat löytäneet uuden kukkakaupan. Eelis Berglund">
				<img class="diks-figure__image" src="https://i.media.fi/incoming/m1n44g/8073375.jpg/alternates/FREE_1440/8073375.jpg"  loading="lazy" decoding="sync" alt="">
			</a>
					<figcaption class="diks-figure__caption">Sara Riekkinen iloitsee, että varkautelaiset ovat löytäneet uuden kukkakaupan. <span class="diks-figure__caption-info">Eelis Berglund</span></figcaption></figure></div>
				</div></div>
		<div class="diks-grid diks-article ">
			<div class="diks-column diks-column--l-span-1 diks-column--xl-span-3"></div>
			<div class="diks-column diks-column--span-4 diks-column--m-span-8 diks-column--l-span-10 diks-column--xl-span-10"><div class="diks-byline ">
		<div class="diks-byline__text-wrapper"><p class="diks-byline__author">Eelis Berglund</p>	<div class="diks-date ">
		<time class="diks-date__published" datetime="2022-06-28T10:41:44+03:00">Tänään 10:41</time>

								</div>
</div></div>
				<div class="diks-meta diks-meta--base diks-meta--size-m diks-meta--align-right"><div class="diks-comment-count diks-comment-count--base diks-comment-count--size-m">
		<span class="coral-count" data-coral-notext="true" data-coral-id="4695482"></span>
	</div><div class="diks-dropdown diks-dropdown--share" ><a class="diks-dropdown__toggler js-diks-toggler " href="#jaa" data-diks-toggle="jaa" data-diks-toggle-class="diks-dropdown__content" aria-label="Näytä jutun jakomahdollisuudet"><span class="diks-icon diks-icon--color-base" aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path fill-rule="evenodd" d="M17 5C15.8954 5 15 5.89543 15 7C15 8.10457 15.8954 9 17 9C18.1046 9 19 8.10457 19 7C19 5.89543 18.1046 5 17 5ZM13 7C13 4.79086 14.7909 3 17 3C19.2091 3 21 4.79086 21 7C21 9.20914 19.2091 11 17 11C15.6148 11 14.3941 10.2959 13.6762 9.22607L9.87377 10.9992C9.95617 11.319 10 11.6544 10 12C10 12.443 9.928 12.8691 9.79506 13.2674L13.53 15.009C14.2203 13.8084 15.5157 13 17 13C19.2091 13 21 14.7909 21 17C21 19.2091 19.2091 21 17 21C14.7909 21 13 19.2091 13 17C13 16.9895 13 16.9791 13.0001 16.9687L8.69117 14.9594C7.98063 15.6059 7.03634 16 6 16C3.79086 16 2 14.2091 2 12C2 9.79086 3.79086 8 6 8C7.14196 8 8.17215 8.47854 8.90098 9.24602L13.0133 7.32842C13.0045 7.22011 13 7.11058 13 7ZM6 10C4.89543 10 4 10.8954 4 12C4 13.1046 4.89543 14 6 14C7.10457 14 8 13.1046 8 12C8 10.8954 7.10457 10 6 10ZM17 15C15.8954 15 15 15.8954 15 17C15 18.1046 15.8954 19 17 19C18.1046 19 19 18.1046 19 17C19 15.8954 18.1046 15 17 15Z" clip-rule="evenodd"/>
</svg>
</span> </a>

		<div id="jaa" class="diks-dropdown__content">
			<ul class="diks-share diks-share--dropdown"><li class="diks-share__item">
					<a class="diks-share__link" aria-label="Jaa Facebookissa" href="https://www.facebook.com/sharer/sharer.php?u=https://www.joroistenlehti.fi/paikalliset/4695482" target="_blank">
						<span class="diks-icon diks-icon--color-inverse" aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path d="M17.302 8.377a.376.376 0 00-.277-.127h-2.828V7.192c0-.21.045-.45.383-.45h2.25a.315.315 0 00.262-.112.352.352 0 00.105-.255v-3A.375.375 0 0016.822 3h-3.247c-3.6 0-3.878 3.075-3.878 4.013V8.25H7.822a.375.375 0 00-.375.375v3a.375.375 0 00.375.375h1.875v8.625a.375.375 0 00.375.375h3.75a.375.375 0 00.375-.375V12h2.513a.375.375 0 00.375-.338l.307-3a.353.353 0 00-.09-.285z"/>
</svg>
</span>
					</a>
				</li><li class="diks-share__item">
					<a class="diks-share__link" aria-label="Jaa Twitterissä" href="https://twitter.com/intent/tweet?text=&amp;url=https://www.joroistenlehti.fi/paikalliset/4695482" target="_blank">
						<span class="diks-icon diks-icon--color-inverse" aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path d="M20.86 7.499a.39.39 0 00-.156-.678l-.616-.148a.382.382 0 01-.257-.218.39.39 0 010-.335l.35-.693a.39.39 0 00-.459-.545l-1.557.436a.374.374 0 01-.335-.07 3.894 3.894 0 00-6.231 3.115v.28a.195.195 0 01-.172.195c-2.188.257-4.283-.856-6.542-3.458a.39.39 0 00-.397-.124.382.382 0 00-.234.342 5.857 5.857 0 00.358 3.832.21.21 0 010 .203.187.187 0 01-.195.078l-.88-.172a.405.405 0 00-.342.117.397.397 0 00-.102.343 4.011 4.011 0 001.846 2.944.195.195 0 01.094.18.187.187 0 01-.117.17l-.42.164a.413.413 0 00-.219.226.398.398 0 000 .312 3.396 3.396 0 002.493 1.931.21.21 0 01.148.171.203.203 0 01-.117.203 8.569 8.569 0 01-3.326.639.398.398 0 00-.156.779 15.514 15.514 0 006.34 1.503 9.813 9.813 0 005.452-1.558 9.72 9.72 0 004.33-8.124v-.677a.382.382 0 01.141-.296l1.277-1.067z"/>
</svg>
</span>
					</a>
				</li><li class="diks-share__item">
					<a class="diks-share__link" aria-label="Jaa WhatsAppissa" href="https://wa.me/?text=https://www.joroistenlehti.fi/paikalliset/4695482" target="_blank">
						<span class="diks-icon diks-icon--color-inverse" aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path d="M11.998 2.896a9.097 9.097 0 00-9.097 9.03 8.893 8.893 0 001.622 5.132L3.492 20.09a.387.387 0 00.09.387.379.379 0 00.388.091l3.176-1.008a9.052 9.052 0 104.852-16.664zm5.458 12.676a2.957 2.957 0 01-2.653 1.585 8.197 8.197 0 01-2.623-.759 10.522 10.522 0 01-4.503-3.912c-1.456-1.918-1.516-3.714-.13-5.2a1.675 1.675 0 011.457-.425 1.16 1.16 0 01.91.667l.295.698.478 1.145a.834.834 0 010 .758c-.194.385-.45.736-.759 1.038a9.73 9.73 0 001.365 1.623c.61.534 1.311.955 2.07 1.243.212-.28.621-.758.758-.97a.758.758 0 011.016-.266c.288.099 1.903.895 1.903.895.206.067.386.197.515.371a1.516 1.516 0 01-.099 1.509z"/>
</svg>
</span>
					</a>
				</li><li class="diks-share__item">
					<a class="diks-share__link" aria-label="Jaa LinkedInissä" href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.joroistenlehti.fi/paikalliset/4695482" target="_blank">
						<span class="diks-icon diks-icon--color-inverse" aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path fill-rule="evenodd" d="M5.554 7.286A2.143 2.143 0 103.43 5.143a2.134 2.134 0 002.125 2.143zM7.286 9H3.857a.429.429 0 00-.428.429V20.57c0 .237.191.429.428.429h3.429a.429.429 0 00.428-.429V9.43A.429.429 0 007.286 9zm12.857 12H17.57a.428.428 0 01-.428-.429v-6.428a2.143 2.143 0 00-4.286 0v6.428a.429.429 0 01-.428.429H9.857a.428.428 0 01-.428-.429V9.43A.429.429 0 019.857 9h2.572a.429.429 0 01.428.429.343.343 0 00.223.317.334.334 0 00.386-.077A3.618 3.618 0 0116.19 8.57c2.555 0 4.38 1.569 4.38 4.8v7.2a.428.428 0 01-.428.429z" clip-rule="evenodd"/>
</svg>
</span>
					</a>
				</li></ul>

		</div>
	</div></div>
				<div id="diks-paywall-sticky__waypoint"></div>
				<div class="diks-article__storyline diks-article__storyline--fade">
														<p>Varkauteen uuden kukka- ja sisustusliikkeen avannut <strong >Suvi Riekkinen </strong>on työskennellyt kauppakeskus Forumissa jo lähes kuukauden ajan. Muutamaa vuotta sitten kukkakauppa-alalle kotikunnassaan Joroisissa palannut Riekkinen päätti yhdessä miehensä <strong >Veijo Santalan</strong> kanssa avata toisen liikkeen Varkauteen. Samalla paikalla aiemmin toiminut yrittäjä otti helmikuussa yhteyttä ja tarjosi tyhjänä ollutta liiketilaa pariskunnan käyttöön.</p>
				</div>
				<div id="diks-paywall-sticky__waypoint"></div><div class="diks-tags-wrapper diks-tags-wrapper--border-bottom">
						<p class="diks-tags__text-before">Lue lisää aiheesta</p><ul class="diks-tags diks-tags--size-s"><li class="diks-tags__tag"><a class="diks-tags__tag-link" href="/aihe/Tekstiilit">Tekstiilit</a></li><li class="diks-tags__tag"><a class="diks-tags__tag-link" href="/aihe/Vaatekappaleet">Vaatekappaleet</a></li><li class="diks-tags__tag"><a class="diks-tags__tag-link" href="/aihe/keng%C3%A4t_ja_asusteet">kengät ja asusteet</a></li><li class="diks-tags__tag"><a class="diks-tags__tag-link" href="/aihe/Koti_ja_asuminen">Koti ja asuminen</a></li><li class="diks-tags__tag"><a class="diks-tags__tag-link" href="/aihe/Perhe">Perhe</a></li></ul>
					</div><div class="diks-display-ad ">
		<div class="diks-display-ad__unit" id="gam-ad-mobiili1" >
			<script>googletag.cmd.push(function() { googletag.display('gam-ad-mobiili1'); });</script>
		</div>
	</div>
				<div class="diks-display-ad ">
		<div class="diks-display-ad__unit" id="gam-ad-mobiili2" >
			<script>googletag.cmd.push(function() { googletag.display('gam-ad-mobiili2'); });</script>
		</div>
	</div>
	<div class="diks-display-ad ">
		<div class="diks-display-ad__unit" id="gam-ad-jattiboksi1" >
			<script>googletag.cmd.push(function() { googletag.display('gam-ad-jattiboksi1'); });</script>
		</div>
	</div>


			</div>
		</div>
	</div>

	<div class="diks-paywall  diks-paywall--sticky" id="diks-paywall">
		<div class="diks-container">
			<div class="diks-paywall__campaign"><h2 class="diks-paywall__headline">Haluatko lukea koko jutun?</h2><p class="diks-paywall__text">Tilaa digi ja pääset lukemaan kaikki Joroisten Lehden sisällöt.</p><p>								<a class="diks-button diks-button--primary" href="https://media.portal.worldoftulo.com/v2/shop/muuri_jorl?utm_source=verkko&amp;utm_medium=maksumuuri&amp;utm_campaign=tilaustarjous&amp;utm_content=jorl_tarjous&amp;accountOrigin=JORL&amp;returnUrl=https%3A%2F%2Fwww.joroistenlehti.fi%2Fpaikalliset%2F4695482&amp;articleid=4695482&amp;cd_source_button=article_paywall&amp;source=maksumuuri_artikkeli" >Tilaa 1 kk 1 €</a></p><p class="diks-paywall__more-info-trigger" id="diks-paywall__more-info-trigger">
					Digitilauksen sisältö
					<span class="diks-icon " aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path fill-rule="evenodd" d="M5.29297 9.70711L6.70718 8.2929L12.0001 13.5858L17.293 8.2929L18.7072 9.70711L12.0001 16.4142L5.29297 9.70711Z" clip-rule="evenodd"/>
</svg>
</span>
					<span class="diks-icon diks-icon--hidden" aria-hidden="true"><svg role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 24 24">
  <path fill-rule="evenodd" d="M18.707 14.2929L17.2928 15.7071L11.9999 10.4142L6.70703 15.7071L5.29282 14.2929L11.9999 7.58578L18.707 14.2929Z" clip-rule="evenodd"/>
</svg>
</span>
				</p>
				<div class="diks-paywall__more-info" id="diks-paywall__more-info">
					<ul><li>Joroistenlehti.fi-verkkopalvelun rajaton käyttöoikeus vuoden jokaisena päivänä</li><li>Näköislehti</li><li>Uutissovelluksen ja päivän lehti -sovelluksen käyttöoikeus (iOS ja Android)</li><li>Lukuoikeus sinulle ja kolmelle perheenjäsenellesi</li></ul>
				</div>
			</div>
		</div><div class="diks-paywall__login">
				<div class="diks-container">
					<p class="diks-paywall__login-text">Oletko jo tilaaja? <a class="diks-paywall__login-link" id="diks-paywall-login-link" href="/kirjaudu/">Kirjaudu</a></p>
				</div>
			</div></div><script src="/theme/css/includes/waypoints/lib/noframework.waypoints.min.js"></script><script>
	// TODO/REWRITE: Use generic toggler if possible
	// More info element
	var paywallMoreInfoTrigger = document.getElementById("diks-paywall__more-info-trigger");
	// More info content
	var paywallMoreInfoContent = document.getElementById("diks-paywall__more-info");
	// Toggle paywall's more info content visibility
	paywallMoreInfoTrigger.addEventListener("click", paywallToggleMoreInfo);

	function paywallToggleMoreInfo() {
		paywallMoreInfoContent.classList.toggle('diks-paywall__more-info--open');
		paywallMoreInfoTrigger.classList.toggle('diks-paywall__more-info-trigger--open');
		// Toggle icon
		children = paywallMoreInfoTrigger.querySelectorAll('.diks-icon');
		for (var j= 0; j < children.length; j++){
			children[j].classList.toggle('diks-icon--hidden');
		}
	}


	// Specify loginLink element + add returnUrl parameter to its href
	var loginLink = document.querySelector('#diks-paywall-login-link');
	loginLink.href = loginLink.href + "?returnUrl="+encodeURIComponent(window.location.href.split('?')[0]);// Sticky paywall
		// Paywall element
		var paywallElement = document.getElementById("diks-paywall");
		// Target element to which paywall visibility is bound to
		var paywallTargetElement = document.getElementById("diks-paywall-sticky__waypoint");

		// Handle paywall visibility (show/hide)
		if (paywallElement && paywallTargetElement) {
			var waypointPaywall = new Waypoint({
				element: paywallTargetElement,
				handler: function() {
					if (paywallElement.classList.contains("diks-paywall--sticky-is-visible")) {
						paywallElement.classList.remove("diks-paywall--sticky-is-visible");

						// Close more info content (with a timeout, so that transition is smooth)
						setTimeout(function() {
							paywallMoreInfoContent.classList.remove('diks-paywall__more-info--open');
							paywallMoreInfoTrigger.classList.remove('diks-paywall__more-info-trigger--open');
						}, 1000);
					} else {
						paywallElement.classList.add("diks-paywall--sticky-is-visible");
					}
				},
				offset: "75%"
			});
		}</script>

		</div>

					
		<footer class="diks-footer">
	<div class="diks-container"><div class="diks-footer__top"><nav class="diks-navigation-wrapper " >
		<ul class="diks-navigation diks-navigation--row" ><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/">Etusivu</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/uusimmat/">Uusimmat</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/luetuimmat/">Luetuimmat</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/paikalliset/">Paikalliset</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/urheilu/">Urheilu</a>
					</li><li class="diks-navigation__item " >
						<a class="diks-navigation__link" href="/paakirjoitus-mielipide/">Pääkirjoitus &amp; mielipide</a>
					</li></ul>
	</nav></div><div class="diks-footer__main">
				<div class="diks-grid">
					<div class="diks-column diks-column--span-4 diks-column--m-span-8 diks-column--l-span-4 diks-column--xl-span-4">
						<p><img class="diks-footer__main-logo--narrow" src="https://a.joroistenlehti.fi/styles/9d7423e4/images/logos/joroistenlehti-black.svg" alt="Joroisten Lehti"></p>
						<p><strong>Postiosoite:</strong> PL 68, 70101 Kuopio<br><strong>Käyntiosoite:</strong> Joroisniementie 4, Joroinen<br><strong>Vastaava päätoimittaja:</strong> Sari Ristamäki</p></div>

					<div class="diks-column diks-column--span-4 diks-column--m-span-8 diks-column--l-span-4 diks-column--xl-span-5"><a href="https://vastuullistajournalismia.fi/"><img class="diks-footer__main-secondary-logo" src="https://a.joroistenlehti.fi/styles/9d7423e4/images/logos/vastuullista-journalismia.png" alt="Vastuullisen journalismin merkki kertoo, että sitä käyttävä media on sitoutunut noudattamaan Julkisen sanan neuvoston laatimia Journalistin ohjeita."></a><div class="diks-footer__main-links-wrapper">
		<div class="diks-column diks-column--span-2"><a class="diks-footer__main-link" href="https://www.keskisuomalainen.com/tietosuojalauseke/">Tietosuojalauseke</a><a class="diks-footer__main-link" href="javascript:window.gravitoCMP.openPreferences();">Evästevalinnat</a></div>
		<div class="diks-column diks-column--span-2"><a class="diks-footer__main-link" href="https://oma.media.fi/joroisten-lehti/">Asiakaspalvelu</a><a class="diks-footer__main-link" href="https://www.meks.fi/mainonta/alueet/savon-media/">Mediamyynti</a><a class="diks-footer__main-link" href="https://oma.media.fi/joroisten-lehti/yhteystiedot/">Yhteystiedot</a></div>
	</div></div>

					<div class="diks-column diks-column--span-4 diks-column--m-span-8 diks-column--l-span-4 diks-column--xl-span-5">
						<h2 class="diks-footer__main-title">Sovellukset</h2><p><strong>Uutissovellus</strong> sisältää tuoreet juttumme, joita ilmestyy ympäri vuorokauden vuoden jokaisena päivänä.</p><p><a class="diks-button " href="/asenna/" >Asenna uutissovellus</a></p><p><strong>Päivän lehti -sovellus</strong> sisältää näköislehtemme liitteineen sekä näköislehtien arkiston. Asenna sovellus laitteesi sovelluskaupasta.</p><div class="diks-footer__main-app-image-wrapper">
				<a class="diks-apps__replica-link diks-hide-on-android" href="https://apps.apple.com/fi/app/joroisten-lehti/id1512773421?l=fi"><img class="diks-apps__replica-image" src="https://a.joroistenlehti.fi/styles/9d7423e4/images/default/appstore-badge.svg" alt="App Store"></a>
				<a class="diks-apps__replica-link diks-hide-on-ios" href="https://play.google.com/store/apps/details?id=fi.joroistenlehti&amp;gl=FI"><img class="diks-apps__replica-image" src="https://a.joroistenlehti.fi/styles/9d7423e4/images/default/google-play-badge.svg" alt="Play Kauppa"></a>
			</div>
						
					</div>
				</div>
			</div><div class="diks-footer__bottom">
				<div class="diks-footer__bottom-row"><div class="diks-footer__bottom-logo-wrapper"><a href="https://www.keskisuomalainen.com/"><img class="diks-footer__bottom-logo" src="https://a.joroistenlehti.fi/styles/9d7423e4/images/logos/keskisuomalainen-sign.svg" alt="Keskisuomalainen Oyj"></a></div>
			<span>Olemme osa Keskisuomalainen-konsernia.</span>
		</div>
				<div class="diks-footer__bottom-link-farm-wrapper">
			<p><strong>Etelä-Suomen Media</strong>: <a class='diks-footer__bottom-link-farm-item' href='https://www.aamuposti.fi/'>Aamuposti</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.helsinginuutiset.fi/'>Helsingin Uutiset</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.karkkilantienoo.fi/'>Karkkilan Tienoo</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.keski-uusimaa.fi/'>Keski-Uusimaa</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.lopenlehti.fi/'>Lopen Lehti</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.loviisansanomat.fi/'>Loviisan Sanomat</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.luoteis-uusimaa.fi/'>Luoteis-Uusimaa</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.lansi-uusimaa.fi/'>Länsi-Uusimaa</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.lansivayla.fi/'>Länsiväylä</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.mantsalanuutiset.fi/'>Mäntsälän Uutiset</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.nurmijarvenuutiset.fi/'>Nurmijärven Uutiset</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.pyhtaanlehti.fi/'>Pyhtäänlehti</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.seinajoensanomat.fi/'>Seinäjoen Sanomat</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.sipoonsanomat.fi/'>Sipoon Sanomat</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.tamperelainen.fi/'>Tamperelainen</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.turkulainen.fi/'>Turkulainen</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.uusimaa.fi/'>Uusimaa</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.vantaansanomat.fi/'>Vantaan Sanomat</a></p><p><strong>Hämeen Media</strong>: <a class='diks-footer__bottom-link-farm-item' href='https://www.ess.fi/'>Etelä-Suomen Sanomat</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.itahame.fi/'>Itä-Häme</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.keski-hame.fi/'>Keski-Häme</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.seutuneloset.fi/'>Seutuneloset</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.uusilahti.fi/'>Uusi Lahti</a></p><p><strong>Hämeen Sanomat Oy</strong>: <a class='diks-footer__bottom-link-farm-item' href='https://www.hameensanomat.fi/'>Hämeen Sanomat</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.forssanlehti.fi/'>Forssan Lehti</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.hameensanomat.fi/kaupunkiuutiset/'>Hämeenlinnan Kaupunkiuutiset</a></p><p><strong>Kaakon Viestintä</strong>: <a class='diks-footer__bottom-link-farm-item' href='https://www.esaimaa.fi/'>Etelä-Saimaa</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.ita-savo.fi/'>Itä-Savo</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.juvanlehti.fi/'>Juvan Lehti</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.kaakonkulma.fi/'>Kaakonkulma</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.kangasniemenlehti.fi/'>Kangasniemen Kunnallislehti</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.keskilaakso.fi/'>Keskilaakso</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.kouvolansanomat.fi/'>Kouvolan Sanomat</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.kymensanomat.fi/'>Kymen Sanomat</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.lappeenrannanuutiset.fi/'>Lappeenrannan Uutiset</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.luumaenlehti.fi/'>Luumäen Lehti</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.lansisaimaa.fi/'>Länsi-Saimaan Sanomat</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.lansi-savo.fi/'>Länsi-Savo</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.mikkelinkaupunkilehti.fi/'>Mikkelin Kaupunkilehti</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.joutsenolehti.fi/'>Paikallislehti Joutseno</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.pitajanuutiset.fi/'>Pitäjänuutiset</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.puruvesi.net/'>Puruvesi</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.uutisvuoksi.fi/'>Uutisvuoksi</a></p><p><strong>Keski-Suomen Media</strong>: <a class='diks-footer__bottom-link-farm-item' href='https://www.hankasalmensanomat.fi/'>Hankasalmen Sanomat </a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.ksml.fi/'>Keskisuomalainen</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.laukaa-konnevesi.fi/'>Laukaa-Konnevesi</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.sampolehti.fi/'>Sampo</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.sisasuomenlehti.fi/'>Sisä-Suomen Lehti</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.sjl.fi/'>Suur-Jyväskylän Lehti</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.viispiikkinen.fi/'>Viispiikkinen</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.viitasaarenseutu.fi/'>Viitasaaren Seutu</a></p><p><strong>Savon Media</strong>: <a class='diks-footer__bottom-link-farm-item' href='https://www.heinavedenlehti.fi/'>Heinäveden Lehti</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.iisalmensanomat.fi/'>Iisalmen Sanomat</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.joroistenlehti.fi/'>Joroisten Lehti</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.koillis-savo.fi/'>Koillis-Savo</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.mattijaliisa.fi/'>Matti ja Liisa</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.miilu.fi/'>Miilu</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.pieksamaenlehti.fi/'>Pieksämäen Lehti</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.pielavesi-keitele.fi/'>Pielavesi-Keitele</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.pitajalainen.fi/'>Pitäjäläinen</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.savonsanomat.fi/'>Savon Sanomat</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.sisa-savolehti.fi/'>Sisä-Savo</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.soisalonseutu.fi/'>Soisalon Seutu</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.tollotin.fi/'>Töllötin</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.uutis-jousi.fi/'>Uutis-Jousi</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.viikkosavo.fi/'>Viikkosavo</a> &bull; <a class='diks-footer__bottom-link-farm-item' href='https://www.warkaudenlehti.fi/'>Warkauden Lehti</a></p>
		</div>
			</div></div>
</footer>

		
					<script>
	if (!DOMTokenList.prototype.replace) {
		// IE Polyfill
		DOMTokenList.prototype.replace = function (a, b) {
			if (this.contains(a)) {
					this.add(b);
					this.remove(a);
					return true;
			}
			return false;
		}
	}

	document.querySelector('.diks-no-js').classList.replace('diks-no-js', 'diks-js');

	// User agent sniffing is not reliable and it's going away.
	// Use only to sprinkle a little bit of progressive enhancement on top.
	// Dear Apple, stop lying, iPad on iOS 13 is not a Mac. You're turning into 90s Microsoft.
	var userAgent = navigator.userAgent || navigator.vendor || window.opera;
	if (/android/i.test(userAgent)) {
		document.querySelector('html').classList.add('diks-user-agent--android');
	} else if (/iPad|iPhone|iPod/i.test(userAgent) && !window.MSStream) {
		document.querySelector('html').classList.add('diks-user-agent--ios');
	} else if (/macintosh/i.test(userAgent) && navigator.maxTouchPoints > 1) {
		document.querySelector('html').classList.add('diks-user-agent--ios');
	}
</script>

<script>
	// Fix forEach for IE
	if (window.NodeList && !NodeList.prototype.forEach) {
		NodeList.prototype.forEach = Array.prototype.forEach;
	}

	// Element.closest() needs a polyfill for older browsers.
	// While we only need the closest() functionality for mobile browsers,
	// we don't want the code to fail even on old desktop browsers.
	// https://developer.mozilla.org/en-US/docs/Web/API/Element/closest#Polyfill
	// https://developer.mozilla.org/en-US/docs/Web/API/Element/closest#Browser_compatibility
	if (!Element.prototype.matches) {
		Element.prototype.matches = Element.prototype.msMatchesSelector || Element.prototype.webkitMatchesSelector;
	}

	if (!Element.prototype.closest) {
		Element.prototype.closest = function(s) {
			var el = this;

			do {
				if (el.matches(s)) return el;
				el = el.parentElement || el.parentNode;
			} while (el !== null && el.nodeType === 1);
			return null;
		};
	}

	document.querySelectorAll('.js-diks-toggler').forEach(function(toggler) {
		var target = document.getElementById(toggler.getAttribute('data-diks-toggle'));
		var eventListenerAttached = toggler.getAttribute('data-diks-event-click');

		if (target && !eventListenerAttached) {
			toggler.addEventListener('click', function(e) {
				e.preventDefault();

				var toggleClass = toggler.getAttribute('data-diks-toggle-class');

				if (toggleClass) {
					var isOpenClass = toggleClass + '--is-open';
					var isClosedClass = toggleClass + '--is-closed';

					if (target.classList.contains(isOpenClass)) {
						// Close this toggle
						target.classList.remove(isOpenClass);
						target.classList.add(isClosedClass);
					} else if (target.classList.contains(isClosedClass)) {
						// Open this toggle
						target.classList.remove(isClosedClass);
						target.classList.add(isOpenClass);
					} else {
						// Open this toggle as a fallback
						target.classList.add(isOpenClass);
					}
				} else {
					if (window.getComputedStyle(target).display !== 'none') {
						target.style.display = 'none';
					} else {
						target.style.display = 'block';
					}
				}
			});

			toggler.setAttribute('data-diks-event-click', true);
		}
	});
</script>

<link rel="stylesheet" href="/theme/css/includes/lightgallery/css/lightgallery.min.css">
<script src="/theme/css/includes/lightgallery/js/lightgallery.min.js"></script>
<script src="/theme/css/includes/lightgallery/js/lg-autoplay.min.js"></script>
<script src="/theme/css/includes/lightgallery/js/lg-fullscreen.min.js"></script>
<script src="/theme/css/includes/lightgallery/js/lg-thumbnail.min.js"></script>
<script src="/theme/css/includes/lightgallery/js/lg-zoom.min.js"></script>
<script>
	// lightGallery
	// Separate gallery for every .js-lightgallery
	// Gallery items come from .js-lightgallery .js-lightgallery__link
	// https://sachinchoolur.github.io/lightgallery.js/docs/api.html
	document.querySelectorAll('.js-diks-lightgallery').forEach(function(gallery) {
		// Thumbnails come from img inside the links, unless links specify data-thumbnail
		var thumbnailSource = (gallery.getElementsByClassName('diks-gallery__link')[0].hasAttribute('data-thumbnail')) ? ('data-thumbnail') : (false);

		// Initialize
		lightGallery(gallery, {
			actualSize: false, // Enable actual pixel icon
			download: false, // Enable download button
			hideControlOnEnd: true, // Hide prev/next button on first/last image
			loop: false, // Ability to loop back to beginning from last element
			exThumbImage: thumbnailSource,
			selector: '.diks-gallery__link' // Custom selector instead of just child
		});
	});
</script><script>
	// Service Worker
	if ('serviceWorker' in navigator) {
		window.addEventListener('load', function() {
			navigator.serviceWorker.register('/sw.js').then(
				function(registration) {
					console.log('PWA: Service worker registered to scope: ', registration.scope);
				},
				function(err) {
					console.error('PWA: Service worker failed to register with error: ', err);
				}
			);
		});
	}

	// Show installation option, hide generic fallback instructions
	function pwaShowInstallationOption() {
		document.querySelectorAll('.js-diks-apps-pwa-installation').forEach(function(element) {
			element.style.display = 'block';
		});
		document.querySelectorAll('.js-diks-apps-pwa-instructions').forEach(function(element) {
			element.style.display = 'none';
		});
	}

	let deferredPrompt;
	var dataLayer = window.dataLayer || [];

	// Basic installation process
	window.addEventListener('beforeinstallprompt', (e) => {
		// Stash the event so it can be triggered later
		deferredPrompt = e;

		// Update the UI to notify the user they can install PWA
		pwaShowInstallationOption();

		// Handle installation
		document.querySelectorAll('.js-diks-apps-pwa-installation-button').forEach(function(button) {
			button.addEventListener('click', (e) => {
				// Show the prompt
				deferredPrompt.prompt();

				// Wait for user to respond
				deferredPrompt.userChoice.then((choiceResult) => {
					if (choiceResult.outcome === 'accepted') {
						console.log('PWA: Installed (prompt)');
						dataLayer.push({
							'event': 'PWA.installation',
							'eventData': 'success'
						});
					} else {
						console.log('PWA: User dismissed installation prompt');
						dataLayer.push({
							'event': 'PWA.installation',
							'eventData': 'canceled'
						});
					}
					deferredPrompt = null;
				});
			});
		});
	});

	// iOS installation process (show instructions modal)
	if (!navigator.standalone) {
		var userAgent = navigator.userAgent.toLowerCase();
		var iPhoneUser = (/iphone/.test(userAgent));
		var iPadUser = (/ipad/.test(userAgent) || (/macintosh/.test(userAgent) && navigator.maxTouchPoints > 1));
		var safariUser = (/^(?!.*(brave|chrome|crios|duckduckgo|edgeios|firefox|fxios|opios|ucbrowser|yabrowser)).*safari.*$/.test(userAgent));

		if (safariUser && (iPhoneUser || iPadUser)) {
			// Update the UI to notify the user they can install PWA
			pwaShowInstallationOption();

			// Instructions
			var modals = document.querySelectorAll('.js-diks-apps-pwa-ios-instructions').forEach(function(element) {
				// Position on screen based on device
				if (iPhoneUser) {
					element.classList.add('diks-apps__pwa-ios-modal--bottom');
				} else if (iPadUser) {
					element.classList.add('diks-apps__pwa-ios-modal--top');
				}
			});

			// Handle modal instructions from installation button
			document.querySelectorAll('.js-diks-apps-pwa-installation-button').forEach(function(button) {
				button.addEventListener('click', (e) => {
					// Show first modal
					document.querySelector('.js-diks-apps-pwa-ios-instructions').classList.toggle('diks-apps__pwa-ios-modal--is-visible');
					dataLayer.push({
						'event': 'PWA.instructions.shown',
						'eventData': 'iOS'
					});
				});
			});
		}
	}
</script>
							<script class="coral-script" src="//coral.diks.fi/assets/js/count.js" defer></script>
			</body>
</html>
